summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
diff options
context:
space:
mode:
authorLokesh Vutla <lokeshvutla@ti.com>2021-06-28 20:18:05 +0530
committerYogesh Siraswar <yogeshs@ti.com>2021-06-29 03:06:46 +0000
commit4a63e03c6310b163bc89c68b005383b92bd3e226 (patch)
treec819616871d1231fc78b1e1fbcdc05cf4620907c /recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
parent518092b90ab6aa8aa3e39827c2cffc018b7f7367 (diff)
downloadmeta-ti-4a63e03c6310b163bc89c68b005383b92bd3e226.tar.gz
prueth-fw: Update prueth dual emac firmware to 5.6.1508.00.00.001
Update the Prueth Dual Emac firmware to 5.6.15 version Signed-off-by: Lokesh Vutla <lokeshvutla@ti.com> Signed-off-by: Dan Murphy <dmurphy@ti.com> Signed-off-by: Vignesh Raghavendra <vigneshr@ti.com> Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Diffstat (limited to 'recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb')
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
new file mode 100644
index 00000000..c392673e
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb
@@ -0,0 +1,37 @@
1SUMMARY = "PRU Ethernet firmware for AM57xx, AM437x and AM335x"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PR = "r0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "11fecaf08eeed27f2a834c9911edb8a5fb2a23b1"
15BRANCH ?= "ti-linux-firmware"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = ""
22TARGET_ti33x = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf"
23TARGET_ti43x = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf"
24TARGET_am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
25TARGET_am57xx-hs-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
26
27do_install() {
28 install -d ${D}${base_libdir}/firmware/ti-pruss
29 for f in ${TARGET}; do
30 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
31 done
32}
33
34
35FILES_${PN} = "${base_libdir}/firmware"
36
37INSANE_SKIP_${PN} = "arch"