diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-10-29 22:29:08 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-29 15:40:03 -0400 |
commit | 644ab65a9ee8426b63537811c7bec41039bc4a5a (patch) | |
tree | 952bd5bca0aecddad35a7b4724f9eb1d20db50e5 /recipes-bsp/pru/pru-icss_git.bb | |
parent | ae61b347ac029fb8b927c22af8946f8eeaaf6d09 (diff) | |
download | meta-ti-644ab65a9ee8426b63537811c7bec41039bc4a5a.tar.gz |
pru-icss: Add PRU software package version 4.0.0.0
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pru/pru-icss_git.bb')
-rw-r--r-- | recipes-bsp/pru/pru-icss_git.bb | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/recipes-bsp/pru/pru-icss_git.bb b/recipes-bsp/pru/pru-icss_git.bb new file mode 100644 index 00000000..b756713e --- /dev/null +++ b/recipes-bsp/pru/pru-icss_git.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | DESCRIPTION = "Programmable Real-time Unit Software Package" | ||
2 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/PRU-ICSS" | ||
3 | LICENSE = "BSD-3-Clause & GPL-2.0 & PD" | ||
4 | |||
5 | LIC_FILES_CHKSUM = "file://PRU-Package-v4.0-Manifest.html;md5=5ea937e4ff2c924a735d42e61ad8cbe3" | ||
6 | |||
7 | BRANCH = "master" | ||
8 | SRC_URI = "git://git.ti.com/pru-software-support-package/pru-software-support-package.git;protocol=git;branch=${BRANCH}" | ||
9 | SRCREV = "476289eb7c3a91977bae84aea55c56f3120b48ea" | ||
10 | |||
11 | PV = "4.0.0.0" | ||
12 | PR = "r0" | ||
13 | |||
14 | require recipes-ti/includes/ti-paths.inc | ||
15 | |||
16 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15" | ||
17 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
18 | |||
19 | DEPENDS = "ti-cgt-pru-native" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | export PRU_CGT = "${TI_CGT_PRU_INSTALL_DIR}" | ||
24 | |||
25 | SUBDIRS = "examples pru_cape/pru_fw lib/src labs" | ||
26 | |||
27 | do_compile() { | ||
28 | for dir in ${SUBDIRS} | ||
29 | do | ||
30 | make -C ${S}/$dir | ||
31 | done | ||
32 | } | ||
33 | |||
34 | do_install_ti33x() { | ||
35 | install -d ${D}/lib/firmware | ||
36 | for i in 0 1 | ||
37 | do | ||
38 | install -m 0644 ${S}/examples/am335x/PRU_RPMsg_Echo_Interrupt${i}/gen/PRU_RPMsg_Echo_Interrupt${i}.out \ | ||
39 | ${D}/lib/firmware/am335x-pru${i}-fw | ||
40 | done | ||
41 | } | ||
42 | |||
43 | do_install_ti43x() { | ||
44 | install -d ${D}/lib/firmware | ||
45 | for i in 0 1 | ||
46 | do | ||
47 | install -m 0644 ${S}/examples/am437x/PRU_RPMsg_Echo_Interrupt${i}/gen/PRU_RPMsg_Echo_Interrupt${i}.out \ | ||
48 | ${D}/lib/firmware/am437x-pru1_${i}-fw | ||
49 | done | ||
50 | } | ||
51 | |||
52 | do_install_omap-a15() { | ||
53 | install -d ${D}/lib/firmware | ||
54 | for i in 1 2 | ||
55 | do | ||
56 | for j in 0 1 | ||
57 | do | ||
58 | install -m 0644 ${S}/examples/am572x/PRU_RPMsg_Echo_Interrupt${i}_${j}/gen/PRU_RPMsg_Echo_Interrupt${i}_${j}.out \ | ||
59 | ${D}/lib/firmware/am57xx-pru${i}_${j}-fw | ||
60 | done | ||
61 | done | ||
62 | } | ||
63 | |||
64 | FILES_${PN} += "/lib/firmware" | ||
65 | |||
66 | INSANE_SKIP_${PN} = "arch" | ||