diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-03-30 17:41:49 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-04-06 18:46:00 -0400 |
commit | f59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca (patch) | |
tree | 247fd11e0b217963fd0a6e6aa061bc0f35248532 /recipes-bsp/powervr-drivers | |
parent | c6d2bd9547ad46577c0d4ca9df7e1f8ab75f2a78 (diff) | |
download | meta-ti-f59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca.tar.gz |
omap3-sgx-modules: Install via the kernel's "modules_install" target.
* This allows the modules to have a consistent installation structure
when directly building from source.
* Previously, these modules would be manualy installed to appears as
in-tree modules.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
4 files changed, 8 insertions, 46 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb index bd476f01..a54a643b 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.05.00.03.bb | |||
@@ -10,7 +10,7 @@ BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "b" | 13 | MACHINE_KERNEL_PR_append = "c" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | DEFAULT_PREFERENCE_omap3 = "99" | 16 | DEFAULT_PREFERENCE_omap3 = "99" |
@@ -32,17 +32,8 @@ TI_PLATFORM_ti814x = "ti81xx" | |||
32 | TI_PLATFORM_ti816x = "ti81xx" | 32 | TI_PLATFORM_ti816x = "ti81xx" |
33 | TI_PLATFORM_ti33x = "ti335x" | 33 | TI_PLATFORM_ti33x = "ti335x" |
34 | 34 | ||
35 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
36 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
37 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
38 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
39 | |||
40 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}" | 35 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM}" |
41 | 36 | ||
42 | do_install() { | 37 | do_install() { |
43 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | 38 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install |
44 | cp ${S}/pvrsrvkm.ko \ | ||
45 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
46 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
47 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
48 | } | 39 | } |
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb index 4b97bbc4..cd6dbe42 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb | |||
@@ -10,7 +10,7 @@ IMGPV = "1.9.2188537" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "c" | 13 | MACHINE_KERNEL_PR_append = "d" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | DEFAULT_PREFERENCE = "-1" | 16 | DEFAULT_PREFERENCE = "-1" |
@@ -44,19 +44,10 @@ TI_PLATFORM_ti814x = "ti81xx" | |||
44 | TI_PLATFORM_ti816x = "ti81xx" | 44 | TI_PLATFORM_ti816x = "ti81xx" |
45 | TI_PLATFORM_ti33x = "ti335x" | 45 | TI_PLATFORM_ti33x = "ti335x" |
46 | 46 | ||
47 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
48 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
49 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
50 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
51 | |||
52 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0" | 47 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0" |
53 | 48 | ||
54 | MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1" | 49 | MAKE_TARGETS_append_ti33x = " PM_RUNTIME=1" |
55 | 50 | ||
56 | do_install() { | 51 | do_install() { |
57 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | 52 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install |
58 | cp ${S}/pvrsrvkm.ko \ | ||
59 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
60 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
61 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
62 | } | 53 | } |
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb index a1d95bfc..1ac60da7 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb | |||
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "c" | 13 | MACHINE_KERNEL_PR_append = "d" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" | 16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" |
@@ -55,18 +55,8 @@ TI_PLATFORM_ti816x = "ti81xx" | |||
55 | TI_PLATFORM_ti33x = "ti335x" | 55 | TI_PLATFORM_ti33x = "ti335x" |
56 | TI_PLATFORM_ti43x = "ti43xx" | 56 | TI_PLATFORM_ti43x = "ti43xx" |
57 | 57 | ||
58 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
59 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
60 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
61 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
62 | MODULESLOCATION_ti43x = "dc_ti43xx_linux" | ||
63 | |||
64 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" | 58 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" |
65 | 59 | ||
66 | do_install() { | 60 | do_install() { |
67 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | 61 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install |
68 | cp ${S}/pvrsrvkm.ko \ | ||
69 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
70 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
71 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
72 | } | 62 | } |
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb index 6a07d4f8..cf042fcd 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb | |||
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475" | |||
10 | 10 | ||
11 | inherit module | 11 | inherit module |
12 | 12 | ||
13 | MACHINE_KERNEL_PR_append = "a" | 13 | MACHINE_KERNEL_PR_append = "b" |
14 | PR = "${MACHINE_KERNEL_PR}" | 14 | PR = "${MACHINE_KERNEL_PR}" |
15 | 15 | ||
16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" | 16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" |
@@ -51,18 +51,8 @@ TI_PLATFORM_ti816x = "ti81xx" | |||
51 | TI_PLATFORM_ti33x = "ti335x" | 51 | TI_PLATFORM_ti33x = "ti335x" |
52 | TI_PLATFORM_ti43x = "ti43xx" | 52 | TI_PLATFORM_ti43x = "ti43xx" |
53 | 53 | ||
54 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
55 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
56 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
57 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
58 | MODULESLOCATION_ti43x = "dc_ti43xx_linux" | ||
59 | |||
60 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" | 54 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" |
61 | 55 | ||
62 | do_install() { | 56 | do_install() { |
63 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | 57 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install |
64 | cp ${S}/pvrsrvkm.ko \ | ||
65 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
66 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
67 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
68 | } | 58 | } |