summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-08-05 12:12:15 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-08-05 13:06:31 -0400
commitf7b1140774e6c8c8aecde41388d40d9d407df6ff (patch)
tree59e72c4aa9c9b1ab1d90e20e8d4847f69e8ab757 /recipes-bsp/powervr-drivers
parent68b5408693f2a398a88ecc40956003ce68d2c76d (diff)
downloadmeta-ti-f7b1140774e6c8c8aecde41388d40d9d407df6ff.tar.gz
omap3-sgx-modules: update one of Darren's patches to match change in 3.14 API
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Acked-by: Franklin Cooper Jr. <fcooper@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules-5.01.01.01/0002-SGX-linux-use-platform-data-to-provide-reset-info.patch8
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb2
2 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules-5.01.01.01/0002-SGX-linux-use-platform-data-to-provide-reset-info.patch b/recipes-bsp/powervr-drivers/omap3-sgx-modules-5.01.01.01/0002-SGX-linux-use-platform-data-to-provide-reset-info.patch
index 22b73fdf..5a8d1f1e 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules-5.01.01.01/0002-SGX-linux-use-platform-data-to-provide-reset-info.patch
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules-5.01.01.01/0002-SGX-linux-use-platform-data-to-provide-reset-info.patch
@@ -1,7 +1,7 @@
1From 30a695502496302f804e14eeca90568f067b2db2 Mon Sep 17 00:00:00 2001 1From 7886ef77e4b48a7edd14acbcbe48f6a898251e78 Mon Sep 17 00:00:00 2001
2From: Darren Etheridge <detheridge@ti.com> 2From: Darren Etheridge <detheridge@ti.com>
3Date: Fri, 25 Jul 2014 16:03:14 -0500 3Date: Fri, 25 Jul 2014 16:03:14 -0500
4Subject: [PATCH 2/4] SGX: linux: use platform data to provide reset info 4Subject: [PATCH 2/5] SGX: linux: use platform data to provide reset info
5 5
6In ti-linux-3.14.y we will not have a reset driver unlike ti-linux-3.12.y 6In ti-linux-3.14.y we will not have a reset driver unlike ti-linux-3.12.y
7so this commit removes the dependency on the reset driver and instead 7so this commit removes the dependency on the reset driver and instead
@@ -14,7 +14,7 @@ Signed-off-by: Darren Etheridge <detheridge@ti.com>
14 1 file changed, 28 insertions(+), 6 deletions(-) 14 1 file changed, 28 insertions(+), 6 deletions(-)
15 15
16diff --git a/GFX_Linux_KM/services4/srvkm/env/linux/module.c b/GFX_Linux_KM/services4/srvkm/env/linux/module.c 16diff --git a/GFX_Linux_KM/services4/srvkm/env/linux/module.c b/GFX_Linux_KM/services4/srvkm/env/linux/module.c
17index e03dc00..82d07f4 100644 17index e03dc00..90e16ce 100644
18--- a/GFX_Linux_KM/services4/srvkm/env/linux/module.c 18--- a/GFX_Linux_KM/services4/srvkm/env/linux/module.c
19+++ b/GFX_Linux_KM/services4/srvkm/env/linux/module.c 19+++ b/GFX_Linux_KM/services4/srvkm/env/linux/module.c
20@@ -47,6 +47,10 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. 20@@ -47,6 +47,10 @@ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
@@ -22,7 +22,7 @@ index e03dc00..82d07f4 100644
22 #endif 22 #endif
23 23
24+#ifndef CONFIG_RESET_CONTROLLER 24+#ifndef CONFIG_RESET_CONTROLLER
25+#include <linux/platform_data/gfx-sgx.h> 25+#include <linux/platform_data/sgx-omap.h>
26+#endif 26+#endif
27+ 27+
28 #if defined(SUPPORT_DRI_DRM) && !defined(SUPPORT_DRI_DRM_PLUGIN) 28 #if defined(SUPPORT_DRI_DRM) && !defined(SUPPORT_DRI_DRM_PLUGIN)
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
index 0b1c06f3..a1d95bfc 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "b" 13MACHINE_KERNEL_PR_append = "c"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" 16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"