summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorGou, Hongmei <h-gou@ti.com>2015-08-29 02:08:31 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-08-28 20:03:49 -0400
commit2b585314cc76895a1481ad22f16d95d0837d7c17 (patch)
tree581911f7cbd4dc09e8d57a4380cf6d860bc4b53a /recipes-bsp/powervr-drivers
parent71d8398e9168c6c943c7b914fbd17f38ce50f83c (diff)
downloadmeta-ti-2b585314cc76895a1481ad22f16d95d0837d7c17.tar.gz
omapdrm-pvr: add AM3 and AM4 which use null_window DRM
Bumped driver revs to match latest kernel patches. Signed-off-by: Hongmei Gou <h-gou@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb26
1 files changed, 21 insertions, 5 deletions
diff --git a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
index e2d01cd2..0978b43a 100644
--- a/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
+++ b/recipes-bsp/powervr-drivers/omapdrm-pvr_1.9.2253347.bb
@@ -5,22 +5,38 @@ LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=2b841bf
5 5
6inherit module 6inherit module
7 7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15"
9
8MACHINE_KERNEL_PR_append = "h" 10MACHINE_KERNEL_PR_append = "h"
9PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"
10 12
11BRANCH = "dra7/k4.1" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15BRANCH_omap-a15 = "dra7/k4.1"
16BRANCH_ti33x = "am4/k4.1"
17BRANCH_ti43x = "am4/k4.1"
12 18
13SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" 19SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}"
14S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
15 21
16SRCREV = "e06c0a4e11401534b938b9a7b1c3f27a65db871f" 22SRCREV_omap-a15 = "e06c0a4e11401534b938b9a7b1c3f27a65db871f"
23SRCREV_ti33x = "696eaf6cff0e4ab6abedc3ff639ec158f8a6177f"
24SRCREV_ti43x = "696eaf6cff0e4ab6abedc3ff639ec158f8a6177f"
25
26PVR_NULLDRM_ti33x = "1"
27PVR_NULLDRM_ti43x = "1"
28PVR_NULLDRM_omap-a15 = "0"
29
30EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" PVR_NULLDRM=${PVR_NULLDRM}'
17 31
18EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}"' 32DEVICE_SUB_DIR_omap-a15 = "omap5430"
33DEVICE_SUB_DIR_ti33x = "omap335x"
34DEVICE_SUB_DIR_ti43x = "omap437x"
19 35
20do_compile_prepend() { 36do_compile_prepend() {
21 cd ${S}/eurasia_km/eurasiacon/build/linux2/omap5430_linux 37 cd ${S}/eurasia_km/eurasiacon/build/linux2/${DEVICE_SUB_DIR}_linux
22} 38}
23 39
24do_install() { 40do_install() {
25 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary2_omap5430_linux_release/target/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install 41 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary2_${DEVICE_SUB_DIR}_linux_release/target/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
26} 42}