summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorChase Maupin <Chase.Maupin@ti.com>2013-04-05 13:28:40 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-04-05 19:30:36 -0400
commitc14c386946e1ea341faeea292580e37d538d645d (patch)
tree38f6867b90b7916b59d84515d81394ee64f5295b /recipes-bsp/powervr-drivers
parent815fde974bb031a3390f4b5501b44bab742cde8c (diff)
downloadmeta-ti-c14c386946e1ea341faeea292580e37d538d645d.tar.gz
ti-graphics: Add latest 4.09.00.01 version
* Add the latest 4.09.00.01 version of the graphis SDK. This version will compile against the latest v3.8 kernel. Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
new file mode 100644
index 00000000..55e427f6
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
@@ -0,0 +1,56 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_09_00_01"
9IMGPV = "1.9.2188537"
10BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "a"
15PR = "${MACHINE_KERNEL_PR}"
16
17DEFAULT_PREFERENCE = "-1"
18
19SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}"
20
21SRC_URI[md5sum] = "bd35e9d8843aff3a2aca9d41e7db1c7d"
22SRC_URI[sha256sum] = "eb37f75ddde4640b09e760fa86e689beb394330ecdf68786188c34f249247647"
23
24TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
25S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
26
27PVRBUILD = "release"
28export KERNELDIR = "${STAGING_KERNEL_DIR}"
29
30INHIBIT_PACKAGE_STRIP = "1"
31
32TI_PLATFORM_omap3 = "omap3630"
33TI_PLATFORM_ti814x = "ti81xx"
34TI_PLATFORM_ti816x = "ti81xx"
35TI_PLATFORM_ti33x = "ti335x"
36
37MODULESLOCATION_omap3 = "dc_omapfb3_linux"
38MODULESLOCATION_ti814x = "dc_ti81xx_linux"
39MODULESLOCATION_ti816x = "dc_ti81xx_linux"
40MODULESLOCATION_ti33x = "dc_ti335x_linux"
41
42export SUPPORT_XORG ?= "${@base_contains('DISTRO_FEATURES', 'x11', '1', '0', d)}"
43
44MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
45
46do_install() {
47 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
48 cp ${S}/pvrsrvkm.ko \
49 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
50 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
51 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
52
53 if [ "${SUPPORT_XORG}" = "1" ]; then
54 cp ${S}/services4/3rdparty/linux_drm/drm.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
55 fi
56}