summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-06-21 03:54:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-06-23 17:56:56 -0400
commit171d3312e50793281d99f06d4248478d5777aa7c (patch)
treeec81e200d4af491319b960e3cce02bac38b64c7d /recipes-bsp/powervr-drivers
parent5a82920f4f2fe7b4a4cd723521464c08d3a870e4 (diff)
downloadmeta-ti-171d3312e50793281d99f06d4248478d5777aa7c.tar.gz
libgles-omap3, omap3-sgx-modules: remove old 4.8.x and 5.x versions
Leave 4.9 as the last release providing softfp binaries and x11 support. Leave 4.5 for now as being widely used on legacy omap3 devices. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.01.bb54
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb54
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb67
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb67
4 files changed, 0 insertions, 242 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.01.bb
deleted file mode 100644
index e9f71904..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.01.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_08_00_01"
9IMGPV = "1.9.2139099"
10BINFILE = "Graphics_SDK_setuplinux_${SGXPV}.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "a"
15PR = "${MACHINE_KERNEL_PR}"
16
17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}"
18
19SRC_URI[md5sum] = "dd0d994a48ecc4293f272a1fddddf159"
20SRC_URI[sha256sum] = "fd721288c95314e0d676dd89462e1dec994e185cb608bcb8ac4a4b5809f9693a"
21
22TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
23S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
24
25PVRBUILD = "release"
26export KERNELDIR = "${STAGING_KERNEL_DIR}"
27
28INHIBIT_PACKAGE_STRIP = "1"
29
30TI_PLATFORM_omap3 = "omap3630"
31TI_PLATFORM_ti814x = "ti81xx"
32TI_PLATFORM_ti816x = "ti81xx"
33TI_PLATFORM_ti33x = "ti335x"
34
35MODULESLOCATION_omap3 = "dc_omapfb3_linux"
36MODULESLOCATION_ti814x = "dc_ti81xx_linux"
37MODULESLOCATION_ti816x = "dc_ti81xx_linux"
38MODULESLOCATION_ti33x = "dc_ti335x_linux"
39
40export SUPPORT_XORG ?= "${@base_contains('DISTRO_FEATURES', 'x11', '1', '0', d)}"
41
42MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
43
44do_install() {
45 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
46 cp ${S}/pvrsrvkm.ko \
47 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
48 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
49 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
50
51 if [ "${SUPPORT_XORG}" = "1" ]; then
52 cp ${S}/services4/3rdparty/linux_drm/drm.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
53 fi
54}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb
deleted file mode 100644
index d5737cdf..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.08.00.02.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ea5743acf520dd81ca172e69f818a3d4"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "4_08_00_02"
9IMGPV = "1.9.2188537"
10BINFILE = "Graphics_SDK_setuplinux_${SGXPV}_minimal_demos.bin"
11
12inherit module
13
14MACHINE_KERNEL_PR_append = "a"
15PR = "${MACHINE_KERNEL_PR}"
16
17SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE}"
18
19SRC_URI[md5sum] = "0efa3a38266e6f41f8cc4fad0187f0d6"
20SRC_URI[sha256sum] = "c732044b515a598e1fab661b7463aa9c53d4fa37f4980dfa85cd02b7468d0cd9"
21
22TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
23S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
24
25PVRBUILD = "release"
26export KERNELDIR = "${STAGING_KERNEL_DIR}"
27
28INHIBIT_PACKAGE_STRIP = "1"
29
30TI_PLATFORM_omap3 = "omap3630"
31TI_PLATFORM_ti814x = "ti81xx"
32TI_PLATFORM_ti816x = "ti81xx"
33TI_PLATFORM_ti33x = "ti335x"
34
35MODULESLOCATION_omap3 = "dc_omapfb3_linux"
36MODULESLOCATION_ti814x = "dc_ti81xx_linux"
37MODULESLOCATION_ti816x = "dc_ti81xx_linux"
38MODULESLOCATION_ti33x = "dc_ti335x_linux"
39
40export SUPPORT_XORG ?= "${@base_contains('DISTRO_FEATURES', 'x11', '1', '0', d)}"
41
42MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
43
44do_install() {
45 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
46 cp ${S}/pvrsrvkm.ko \
47 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
48 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
49 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
50
51 if [ "${SUPPORT_XORG}" = "1" ]; then
52 cp ${S}/services4/3rdparty/linux_drm/drm.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
53 fi
54}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb
deleted file mode 100644
index e18ce0cc..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_00_00_01"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "a"
14PR = "${MACHINE_KERNEL_PR}"
15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_alpha_hardfp_minimal_demos.bin"
17MD5SUM_HARDFP = "ae6125d7f8a313ea5c02afded893052d"
18SHA256SUM_HARDFP = "c2782a2f85024741722b936ec9dca66b858ae8561aa71b693f11e12d8c0385e0"
19
20# For now we only have hardfp version
21python __anonymous() {
22 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
23 if not tunes:
24 return
25 pkgn = bb.data.getVar("PN", d, 1)
26 pkgv = bb.data.getVar("PV", d, 1)
27 if "callconvention-hard" not in tunes:
28 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
29 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
30}
31
32BINFILE := "${BINFILE_HARDFP}"
33
34SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
35
36SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
37SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
38
39TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
40S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
41
42PVRBUILD = "release"
43export KERNELDIR = "${STAGING_KERNEL_DIR}"
44
45INHIBIT_PACKAGE_STRIP = "1"
46
47TI_PLATFORM_omap3 = "omap3630"
48TI_PLATFORM_ti814x = "ti81xx"
49TI_PLATFORM_ti816x = "ti81xx"
50TI_PLATFORM_ti33x = "ti335x"
51TI_PLATFORM_ti43x = "ti43xx"
52
53MODULESLOCATION_omap3 = "dc_omapfb3_linux"
54MODULESLOCATION_ti814x = "dc_ti81xx_linux"
55MODULESLOCATION_ti816x = "dc_ti81xx_linux"
56MODULESLOCATION_ti33x = "dc_ti335x_linux"
57MODULESLOCATION_ti43x = "dc_ti43xx_linux"
58
59MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
60
61do_install() {
62 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
63 cp ${S}/pvrsrvkm.ko \
64 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
65 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
66 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
67}
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb
deleted file mode 100644
index 162e4d59..00000000
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.00.01.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_01_00_01"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "a"
14PR = "${MACHINE_KERNEL_PR}"
15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
17MD5SUM_HARDFP = "0ee7d59808330d442a51c0990c2cb30e"
18SHA256SUM_HARDFP = "769daae439677a7a85bbbced14cee4f85b19823e0b99560078d0a864c525c128"
19
20# For now we only have hardfp version
21python __anonymous() {
22 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
23 if not tunes:
24 return
25 pkgn = bb.data.getVar("PN", d, 1)
26 pkgv = bb.data.getVar("PV", d, 1)
27 if "callconvention-hard" not in tunes:
28 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
29 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
30}
31
32BINFILE := "${BINFILE_HARDFP}"
33
34SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
35
36SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
37SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
38
39TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
40S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
41
42PVRBUILD = "release"
43export KERNELDIR = "${STAGING_KERNEL_DIR}"
44
45INHIBIT_PACKAGE_STRIP = "1"
46
47TI_PLATFORM_omap3 = "omap3630"
48TI_PLATFORM_ti814x = "ti81xx"
49TI_PLATFORM_ti816x = "ti81xx"
50TI_PLATFORM_ti33x = "ti335x"
51TI_PLATFORM_ti43x = "ti43xx"
52
53MODULESLOCATION_omap3 = "dc_omapfb3_linux"
54MODULESLOCATION_ti814x = "dc_ti81xx_linux"
55MODULESLOCATION_ti816x = "dc_ti81xx_linux"
56MODULESLOCATION_ti33x = "dc_ti335x_linux"
57MODULESLOCATION_ti43x = "dc_ti43xx_linux"
58
59MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
60
61do_install() {
62 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
63 cp ${S}/pvrsrvkm.ko \
64 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
65 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
66 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
67}