diff options
author | Franklin S. Cooper Jr <fcooper@ti.com> | 2014-02-18 22:42:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-02-21 10:55:01 -0500 |
commit | 881c9b5b49455423805df10ae044068a41d53140 (patch) | |
tree | 2a28e68500ec4497fff8dd12a1db71a992fd7f2a /recipes-bsp/powervr-drivers | |
parent | 90f78e4355153a8595b7885e6de696c4b7060091 (diff) | |
download | meta-ti-881c9b5b49455423805df10ae044068a41d53140.tar.gz |
Graphics SDK: Add version 05.01.01.01
* Add latest version of the Graphics SDK that includes bug fixes.
* Fixed Suspend and Resume issue on AM43x.
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb new file mode 100644 index 00000000..40bf8c07 --- /dev/null +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.01.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e" | ||
4 | |||
5 | TI_BIN_UNPK_CMDS="Y: qY:workdir:Y" | ||
6 | require ../../recipes-ti/includes/ti-eula-unpack.inc | ||
7 | |||
8 | SGXPV = "5_01_01_01" | ||
9 | IMGPV = "1.10.2359475" | ||
10 | |||
11 | inherit module | ||
12 | |||
13 | MACHINE_KERNEL_PR_append = "a" | ||
14 | PR = "${MACHINE_KERNEL_PR}" | ||
15 | |||
16 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" | ||
17 | MD5SUM_HARDFP = "94acdbd20152c905939c2448d5e80a72" | ||
18 | SHA256SUM_HARDFP = "7f647bf45a5ce8ba9aaa28c4afe85fced4275f9a4567a1886d4460b76c9051ae" | ||
19 | |||
20 | # For now we only have hardfp version | ||
21 | python __anonymous() { | ||
22 | tunes = bb.data.getVar("TUNE_FEATURES", d, 1) | ||
23 | if not tunes: | ||
24 | return | ||
25 | pkgn = bb.data.getVar("PN", d, 1) | ||
26 | pkgv = bb.data.getVar("PV", d, 1) | ||
27 | if "callconvention-hard" not in tunes: | ||
28 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
29 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
30 | } | ||
31 | |||
32 | BINFILE := "${BINFILE_HARDFP}" | ||
33 | |||
34 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}" | ||
35 | |||
36 | SRC_URI[md5sum] := "${MD5SUM_HARDFP}" | ||
37 | SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}" | ||
38 | |||
39 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | ||
40 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" | ||
41 | |||
42 | PVRBUILD = "release" | ||
43 | export KERNELDIR = "${STAGING_KERNEL_DIR}" | ||
44 | |||
45 | INHIBIT_PACKAGE_STRIP = "1" | ||
46 | |||
47 | TI_PLATFORM_omap3 = "omap3630" | ||
48 | TI_PLATFORM_ti814x = "ti81xx" | ||
49 | TI_PLATFORM_ti816x = "ti81xx" | ||
50 | TI_PLATFORM_ti33x = "ti335x" | ||
51 | TI_PLATFORM_ti43x = "ti43xx" | ||
52 | |||
53 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
54 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
55 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
56 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
57 | MODULESLOCATION_ti43x = "dc_ti43xx_linux" | ||
58 | |||
59 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" | ||
60 | |||
61 | do_install() { | ||
62 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
63 | cp ${S}/pvrsrvkm.ko \ | ||
64 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
65 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
66 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
67 | } | ||