diff options
author | Anand Balagopalakrishnan <anandb@ti.com> | 2018-03-14 02:33:35 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-03-19 13:42:52 -0400 |
commit | cc734a2e6e75b85ae91654e7ca734d3c1d3a44d5 (patch) | |
tree | ffb1bcdfe42263f6d2109de0fa1c4f211bb2b3db /recipes-bsp/powervr-drivers | |
parent | 279cf7e3af28c5d1f8169f3388fc79e1ae654a25 (diff) | |
download | meta-ti-cc734a2e6e75b85ae91654e7ca734d3c1d3a44d5.tar.gz |
ti-sgx-ddk-km: update SGX kernel driver for k4.14
Note: This is a tentative patch to enable graphics support.
We shall merge both local patches to the ti-sgx-km repo soon.
Signed-off-by: Anand Balagopalakrishnan <anandb@ti.com>
Signed-off-by: Eric Ruei <e-ruei1@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-pvr_drm.c-fix-undeclared-identifier-error-for-AM3-4-.patch | 37 | ||||
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb | 5 |
2 files changed, 40 insertions, 2 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-pvr_drm.c-fix-undeclared-identifier-error-for-AM3-4-.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-pvr_drm.c-fix-undeclared-identifier-error-for-AM3-4-.patch new file mode 100644 index 00000000..cde6b3d8 --- /dev/null +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-pvr_drm.c-fix-undeclared-identifier-error-for-AM3-4-.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 1ee059ed47b379c1cd9494c507a4a1e67dc90cf2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Eric Ruei <e-ruei1@ti.com> | ||
3 | Date: Mon, 12 Mar 2018 17:56:50 -0400 | ||
4 | Subject: [PATCH 1/2] pvr_drm.c: fix undeclared identifier error for AM3/4 | ||
5 | builds | ||
6 | |||
7 | The undeclared identifier error was introduced during the k4.14 migration | ||
8 | and therefore was not applicable to the k4.4 and k4.9 branches. | ||
9 | |||
10 | Signed-off-by: Eric Ruei <e-ruei1@ti.com> | ||
11 | --- | ||
12 | eurasia_km/services4/srvkm/env/linux/pvr_drm.c | 6 +++--- | ||
13 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
14 | |||
15 | diff --git a/eurasia_km/services4/srvkm/env/linux/pvr_drm.c b/eurasia_km/services4/srvkm/env/linux/pvr_drm.c | ||
16 | index 39ee832..33f6c3d 100644 | ||
17 | --- a/eurasia_km/services4/srvkm/env/linux/pvr_drm.c | ||
18 | +++ b/eurasia_km/services4/srvkm/env/linux/pvr_drm.c | ||
19 | @@ -655,12 +655,12 @@ static struct platform_driver sPVRPlatDriver = | ||
20 | static int | ||
21 | PVRSRVDrmProbe(struct platform_device *pDevice) | ||
22 | { | ||
23 | -#if (AM_VERSION != 5) | ||
24 | - struct gfx_sgx_platform_data *pdata = dev->platform_data; | ||
25 | -#endif | ||
26 | int ret; | ||
27 | struct device *dev = &pDevice->dev; | ||
28 | struct drm_device *drm_dev; | ||
29 | +#if (AM_VERSION != 5) | ||
30 | + struct gfx_sgx_platform_data *pdata = dev->platform_data; | ||
31 | +#endif | ||
32 | |||
33 | PVR_TRACE(("PVRSRVDrmProbe")); | ||
34 | |||
35 | -- | ||
36 | 1.9.1 | ||
37 | |||
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb index 03037977..09271776 100644 --- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb | |||
@@ -20,15 +20,16 @@ RPROVIDES_${PN} = "omapdrm-pvr" | |||
20 | RREPLACES_${PN} = "omapdrm-pvr" | 20 | RREPLACES_${PN} = "omapdrm-pvr" |
21 | RCONFLICTS_${PN} = "omapdrm-pvr" | 21 | RCONFLICTS_${PN} = "omapdrm-pvr" |
22 | 22 | ||
23 | BRANCH = "ti-img-sgx/${PV}/k4.9" | 23 | BRANCH = "ti-img-sgx/${PV}/k4.14" |
24 | 24 | ||
25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \ | 25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \ |
26 | file://0001-srvkm-common-devicemem.c-suppress-implicit-fallthrou.patch \ | 26 | file://0001-srvkm-common-devicemem.c-suppress-implicit-fallthrou.patch \ |
27 | file://0001-pvr_drm.c-fix-undeclared-identifier-error-for-AM3-4-.patch \ | ||
27 | " | 28 | " |
28 | 29 | ||
29 | S = "${WORKDIR}/git" | 30 | S = "${WORKDIR}/git" |
30 | 31 | ||
31 | SRCREV = "0086977380d3320d70a3abc78b95fa0641427073" | 32 | SRCREV = "855889f437250b6572c75d12696ec4a998b9aef9" |
32 | 33 | ||
33 | TARGET_PRODUCT_omap-a15 = "jacinto6evm" | 34 | TARGET_PRODUCT_omap-a15 = "jacinto6evm" |
34 | TARGET_PRODUCT_ti33x = "ti335x" | 35 | TARGET_PRODUCT_ti33x = "ti335x" |