summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorPrabindh Sundareson <prabu@ti.com>2013-06-12 22:52:35 +0530
committerDenys Dmytriyenko <denys@ti.com>2013-06-21 14:43:24 -0400
commitb9d459af62de7767bcff889c21f70450e563adf9 (patch)
treed8dbf1479fb6fc81153c91d912a162912df6c5f0 /recipes-bsp/powervr-drivers
parentadb1681db776d843bbb0d644557509a73b0b89d5 (diff)
downloadmeta-ti-b9d459af62de7767bcff889c21f70450e563adf9.tar.gz
omap3-sgx-modules: Remove X11 related build and packaging
SGX530 driver for X11 is only buildable and testable standalone with the pre-built X11 package provided with the Graphics SDK. This patch removes X11 build from the default kernel module recipe, to enable moving X11 build to a separate recipe. This is part of a clean up of the Graphics recipe starting from 4.09.00.01 version of the Graphics SDK. Signed-off-by: Prabindh Sundareson <prabu at ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb9
1 files changed, 2 insertions, 7 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
index 55e427f6..923e6a55 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_4.09.00.01.bb
@@ -39,9 +39,7 @@ MODULESLOCATION_ti814x = "dc_ti81xx_linux"
39MODULESLOCATION_ti816x = "dc_ti81xx_linux" 39MODULESLOCATION_ti816x = "dc_ti81xx_linux"
40MODULESLOCATION_ti33x = "dc_ti335x_linux" 40MODULESLOCATION_ti33x = "dc_ti335x_linux"
41 41
42export SUPPORT_XORG ?= "${@base_contains('DISTRO_FEATURES', 'x11', '1', '0', d)}" 42MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=0"
43
44MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
45 43
46do_install() { 44do_install() {
47 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 45 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
@@ -49,8 +47,5 @@ do_install() {
49 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ 47 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
50 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ 48 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
51 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 49 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
52
53 if [ "${SUPPORT_XORG}" = "1" ]; then
54 cp ${S}/services4/3rdparty/linux_drm/drm.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
55 fi
56} 50}
51