diff options
author | Etheridge, Darren <detheridge@ti.com> | 2022-03-23 14:37:07 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-04-07 07:48:39 -0500 |
commit | ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4 (patch) | |
tree | 400e4a95765e82581637257d28607fb087357392 /recipes-bsp/powervr-drivers | |
parent | 1ab91bcc154909f5ba8e04a866836773fa9430e4 (diff) | |
download | meta-ti-ed94c75b436f2f8c5c3a8a6ebed45d7276cc35e4.tar.gz |
ti-graphics: gpu enable and move all platforms to ddk 1.15
Enable the GPU for am62xx and j721s2 and use IMG DDK 1.15
Migrate Imagination DDK 1.13 to DDK 1.15 for J721e
Signed-off-by: Darren Etheridge <detheridge@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb | 40 | ||||
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb | 44 |
2 files changed, 44 insertions, 40 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb deleted file mode 100644 index a05de0f2..00000000 --- a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.13.5776728.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver" | ||
3 | LICENSE = "MIT | GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2" | ||
5 | |||
6 | inherit module features_check | ||
7 | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | ||
9 | |||
10 | MACHINE_KERNEL_PR_append = "b" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | COMPATIBLE_MACHINE = "j7" | ||
15 | |||
16 | DEPENDS = "virtual/kernel" | ||
17 | |||
18 | PROVIDES = "virtual/gpudriver" | ||
19 | |||
20 | BRANCH = "1.13-5776728/linux-k5.10" | ||
21 | |||
22 | SRC_URI = " \ | ||
23 | git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \ | ||
24 | file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \ | ||
25 | " | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | SRCREV = "35a25875ae8738f82c7cabc6b077ef992b0cca84" | ||
30 | |||
31 | PVR_SOC = "j721e_linux" | ||
32 | PVR_BVNC = "22.104.208.318" | ||
33 | PVR_BUILD = "release" | ||
34 | PVR_WS = "wayland" | ||
35 | |||
36 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${PVR_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${PVR_SOC} WINDOW_SYSTEM=${PVR_WS}' | ||
37 | |||
38 | do_install() { | ||
39 | make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${PVR_SOC}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install | ||
40 | } | ||
diff --git a/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb new file mode 100644 index 00000000..fbff6c51 --- /dev/null +++ b/recipes-bsp/powervr-drivers/ti-img-rogue-driver_1.15.6133109.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR Rogue GPU found in the TI SoCs" | ||
2 | HOMEPAGE = "http://git.ti.com/graphics/ti-img-rogue-driver" | ||
3 | LICENSE = "MIT | GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://README;beginline=14;endline=19;md5=0403c7dea01a2b8232261e805325fac2" | ||
5 | |||
6 | inherit module features_check | ||
7 | |||
8 | REQUIRED_MACHINE_FEATURES = "gpu" | ||
9 | |||
10 | MACHINE_KERNEL_PR_append = "a" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | COMPATIBLE_MACHINE = "j7-evm|j721s2-evm|am62xx" | ||
15 | |||
16 | DEPENDS = "virtual/kernel" | ||
17 | |||
18 | PROVIDES = "virtual/gpudriver" | ||
19 | |||
20 | BRANCH = "linuxws/dunfell/k5.10/${PV}" | ||
21 | |||
22 | SRC_URI = " \ | ||
23 | git://git.ti.com/graphics/ti-img-rogue-driver.git;branch=${BRANCH} \ | ||
24 | file://0001-compiler-support-OpenEmbedded-nodistro-internal-aarc.patch \ | ||
25 | " | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | SRCREV = "ee0674adccac16f5b2f7cb8d5d05948706080cb5" | ||
30 | |||
31 | TARGET_PRODUCT_j7-evm = "j721e_linux" | ||
32 | TARGET_PRODUCT_j721s2-evm = "j721s2_linux" | ||
33 | TARGET_PRODUCT_am62xx = "am62_linux" | ||
34 | TARGET_BVNC_j7-evm = "22.104.208.318" | ||
35 | TARGET_BVNC_j721s2-evm = "36.53.104.796" | ||
36 | TARGET_BVNC_am62xx = "33.15.11.3" | ||
37 | PVR_BUILD = "release" | ||
38 | PVR_WS = "wayland" | ||
39 | |||
40 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" RGX_BVNC=${TARGET_BVNC} BUILD=${PVR_BUILD} PVR_BUILD_DIR=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}' | ||
41 | |||
42 | do_install() { | ||
43 | make -C ${STAGING_KERNEL_DIR} M=${B}/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install | ||
44 | } | ||