diff options
author | Denys Dmytriyenko <denys@ti.com> | 2013-11-21 20:41:38 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-11-21 21:51:57 -0500 |
commit | e1351fa79908e257baf6f22082ca23d992d537fc (patch) | |
tree | 32f564895c06f813c9e61e3a07c2fb12b165dc7d /recipes-bsp/powervr-drivers | |
parent | afcfeba4e6e01206952cbdbbc5805b416eb17491 (diff) | |
download | meta-ti-e1351fa79908e257baf6f22082ca23d992d537fc.tar.gz |
omap3-sgx-modules: add new Graphics SDK 05.00.00.01 alpha release
* Initial support for AM43x platform
* 3.12 kernel support for AM335x & AM43x
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb | 69 |
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb new file mode 100644 index 00000000..4a5def2b --- /dev/null +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb | |||
@@ -0,0 +1,69 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e" | ||
4 | |||
5 | TI_BIN_UNPK_CMDS="Y: qY:workdir:Y" | ||
6 | require ../../recipes-ti/includes/ti-eula-unpack.inc | ||
7 | |||
8 | SGXPV = "5_00_00_01" | ||
9 | IMGPV = "1.10.2359475" | ||
10 | |||
11 | inherit module | ||
12 | |||
13 | MACHINE_KERNEL_PR_append = "a" | ||
14 | PR = "${MACHINE_KERNEL_PR}" | ||
15 | |||
16 | DEFAULT_PREFERENCE = "-1" | ||
17 | |||
18 | BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_alpha_hardfp_minimal_demos.bin" | ||
19 | MD5SUM_HARDFP = "ae6125d7f8a313ea5c02afded893052d" | ||
20 | SHA256SUM_HARDFP = "c2782a2f85024741722b936ec9dca66b858ae8561aa71b693f11e12d8c0385e0" | ||
21 | |||
22 | # For now we only have hardfp version | ||
23 | python __anonymous() { | ||
24 | tunes = bb.data.getVar("TUNE_FEATURES", d, 1) | ||
25 | if not tunes: | ||
26 | return | ||
27 | pkgn = bb.data.getVar("PN", d, 1) | ||
28 | pkgv = bb.data.getVar("PV", d, 1) | ||
29 | if "callconvention-hard" not in tunes: | ||
30 | bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
31 | raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv)) | ||
32 | } | ||
33 | |||
34 | BINFILE := "${BINFILE_HARDFP}" | ||
35 | |||
36 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}" | ||
37 | |||
38 | SRC_URI[md5sum] := "${MD5SUM_HARDFP}" | ||
39 | SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}" | ||
40 | |||
41 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | ||
42 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" | ||
43 | |||
44 | PVRBUILD = "release" | ||
45 | export KERNELDIR = "${STAGING_KERNEL_DIR}" | ||
46 | |||
47 | INHIBIT_PACKAGE_STRIP = "1" | ||
48 | |||
49 | TI_PLATFORM_omap3 = "omap3630" | ||
50 | TI_PLATFORM_ti814x = "ti81xx" | ||
51 | TI_PLATFORM_ti816x = "ti81xx" | ||
52 | TI_PLATFORM_ti33x = "ti335x" | ||
53 | TI_PLATFORM_ti43x = "ti43xx" | ||
54 | |||
55 | MODULESLOCATION_omap3 = "dc_omapfb3_linux" | ||
56 | MODULESLOCATION_ti814x = "dc_ti81xx_linux" | ||
57 | MODULESLOCATION_ti816x = "dc_ti81xx_linux" | ||
58 | MODULESLOCATION_ti33x = "dc_ti335x_linux" | ||
59 | MODULESLOCATION_ti43x = "dc_ti43xx_linux" | ||
60 | |||
61 | MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" | ||
62 | |||
63 | do_install() { | ||
64 | mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
65 | cp ${S}/pvrsrvkm.ko \ | ||
66 | ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \ | ||
67 | ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \ | ||
68 | ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr | ||
69 | } | ||