summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-11-21 20:41:38 -0500
committerDenys Dmytriyenko <denys@ti.com>2013-11-21 21:51:57 -0500
commite1351fa79908e257baf6f22082ca23d992d537fc (patch)
tree32f564895c06f813c9e61e3a07c2fb12b165dc7d /recipes-bsp/powervr-drivers
parentafcfeba4e6e01206952cbdbbc5805b416eb17491 (diff)
downloadmeta-ti-e1351fa79908e257baf6f22082ca23d992d537fc.tar.gz
omap3-sgx-modules: add new Graphics SDK 05.00.00.01 alpha release
* Initial support for AM43x platform * 3.12 kernel support for AM335x & AM43x Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb
new file mode 100644
index 00000000..4a5def2b
--- /dev/null
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.00.00.01.bb
@@ -0,0 +1,69 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the omap3 SoCs"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
4
5TI_BIN_UNPK_CMDS="Y: qY:workdir:Y"
6require ../../recipes-ti/includes/ti-eula-unpack.inc
7
8SGXPV = "5_00_00_01"
9IMGPV = "1.10.2359475"
10
11inherit module
12
13MACHINE_KERNEL_PR_append = "a"
14PR = "${MACHINE_KERNEL_PR}"
15
16DEFAULT_PREFERENCE = "-1"
17
18BINFILE_HARDFP = "Graphics_SDK_setuplinux_${SGXPV}_alpha_hardfp_minimal_demos.bin"
19MD5SUM_HARDFP = "ae6125d7f8a313ea5c02afded893052d"
20SHA256SUM_HARDFP = "c2782a2f85024741722b936ec9dca66b858ae8561aa71b693f11e12d8c0385e0"
21
22# For now we only have hardfp version
23python __anonymous() {
24 tunes = bb.data.getVar("TUNE_FEATURES", d, 1)
25 if not tunes:
26 return
27 pkgn = bb.data.getVar("PN", d, 1)
28 pkgv = bb.data.getVar("PV", d, 1)
29 if "callconvention-hard" not in tunes:
30 bb.warn("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
31 raise bb.parse.SkipPackage("%s-%s ONLY supports hardfp mode for now" % (pkgn, pkgv))
32}
33
34BINFILE := "${BINFILE_HARDFP}"
35
36SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/gfxsdk/${SGXPV}/exports/${BINFILE}"
37
38SRC_URI[md5sum] := "${MD5SUM_HARDFP}"
39SRC_URI[sha256sum] := "${SHA256SUM_HARDFP}"
40
41TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}"
42S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM"
43
44PVRBUILD = "release"
45export KERNELDIR = "${STAGING_KERNEL_DIR}"
46
47INHIBIT_PACKAGE_STRIP = "1"
48
49TI_PLATFORM_omap3 = "omap3630"
50TI_PLATFORM_ti814x = "ti81xx"
51TI_PLATFORM_ti816x = "ti81xx"
52TI_PLATFORM_ti33x = "ti335x"
53TI_PLATFORM_ti43x = "ti43xx"
54
55MODULESLOCATION_omap3 = "dc_omapfb3_linux"
56MODULESLOCATION_ti814x = "dc_ti81xx_linux"
57MODULESLOCATION_ti816x = "dc_ti81xx_linux"
58MODULESLOCATION_ti33x = "dc_ti335x_linux"
59MODULESLOCATION_ti43x = "dc_ti43xx_linux"
60
61MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
62
63do_install() {
64 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
65 cp ${S}/pvrsrvkm.ko \
66 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
67 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
68 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
69}