diff options
author | Denys Dmytriyenko <denys@ti.com> | 2019-03-02 03:07:54 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-03-01 21:06:30 +0000 |
commit | 3626c169121796728ebf5926eaf5c0ff5e3fd067 (patch) | |
tree | e158f1967c75ed01560bc73b0540929dad599ccd /recipes-bsp/powervr-drivers | |
parent | 84b3ff8da8311138e534cfb8930c08aa4b417c3e (diff) | |
download | meta-ti-3626c169121796728ebf5926eaf5c0ff5e3fd067.tar.gz |
ti-sgx-ddk: remove old 1.14 version of DDK KM and UM
DDK 1.17 is now supported for same platforms.
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
3 files changed, 0 insertions, 105 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch deleted file mode 100644 index e1d2d10d..00000000 --- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-buildvars.mk-pass-Wno-cast-function-type.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 287ca27cdf9004b4ba9bb0ce30d6139f707246f9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Sun, 14 Oct 2018 19:53:14 -0400 | ||
4 | Subject: [PATCH] buildvars.mk: pass -Wno-cast-function-type | ||
5 | |||
6 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
7 | --- | ||
8 | eurasia_km/eurasiacon/build/linux2/buildvars.mk | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/eurasia_km/eurasiacon/build/linux2/buildvars.mk b/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
12 | index f30e467..f00f852 100644 | ||
13 | --- a/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
14 | +++ b/eurasia_km/eurasiacon/build/linux2/buildvars.mk | ||
15 | @@ -48,7 +48,7 @@ | ||
16 | |||
17 | # These flags are used for kernel, User C and User C++ | ||
18 | # | ||
19 | -COMMON_FLAGS := -W -Wall | ||
20 | +COMMON_FLAGS := -W -Wall -Wno-cast-function-type | ||
21 | |||
22 | # Some GCC warnings are C only, so we must mask them from C++ | ||
23 | # | ||
24 | -- | ||
25 | 2.7.4 | ||
26 | |||
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch deleted file mode 100644 index 96e657d0..00000000 --- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km/0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 353d8b9313abc492e5938171cea4ac697fd991f0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Denys Dmytriyenko <denys@ti.com> | ||
3 | Date: Sun, 14 Oct 2018 19:41:49 -0400 | ||
4 | Subject: [PATCH] srvkm/env/linux/osfunc.c: fix gcc8 stringop-truncation error | ||
5 | |||
6 | gcc8 now checks for strncpy function that potentially truncate the terminating | ||
7 | NUL charcter from the source string. Fails like this: | ||
8 | |||
9 | .../services4/srvkm/env/linux/osfunc.c:3051:13: error: 'strncpy' specified bound 50 equals destination size [-Werror=stringop-truncation] | ||
10 | | strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH); | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
12 | | cc1: all warnings being treated as errors | ||
13 | |||
14 | Signed-off-by: Denys Dmytriyenko <denys@ti.com> | ||
15 | --- | ||
16 | eurasia_km/services4/srvkm/env/linux/osfunc.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/eurasia_km/services4/srvkm/env/linux/osfunc.c b/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
20 | index 02dfe9b..02c8e3b 100644 | ||
21 | --- a/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
22 | +++ b/eurasia_km/services4/srvkm/env/linux/osfunc.c | ||
23 | @@ -3048,7 +3048,7 @@ PVRSRV_ERROR OSEventObjectCreateKM(const IMG_CHAR *pszName, PVRSRV_EVENTOBJECT * | ||
24 | if(pszName) | ||
25 | { | ||
26 | /* copy over the event object name */ | ||
27 | - strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH); | ||
28 | + strncpy(psEventObject->szName, pszName, EVENTOBJNAME_MAXLENGTH-1); | ||
29 | } | ||
30 | else | ||
31 | { | ||
32 | -- | ||
33 | 2.7.4 | ||
34 | |||
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb deleted file mode 100644 index 4283587d..00000000 --- a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.14.3699939.bb +++ /dev/null | |||
@@ -1,45 +0,0 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs" | ||
2 | HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux" | ||
3 | LICENSE = "MIT | GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12" | ||
5 | |||
6 | inherit module | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15" | ||
9 | |||
10 | MACHINE_KERNEL_PR_append = "p" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | DEPENDS = "virtual/kernel" | ||
16 | |||
17 | PROVIDES = "omapdrm-pvr" | ||
18 | |||
19 | RPROVIDES_${PN} = "omapdrm-pvr" | ||
20 | RREPLACES_${PN} = "omapdrm-pvr" | ||
21 | RCONFLICTS_${PN} = "omapdrm-pvr" | ||
22 | |||
23 | BRANCH = "ti-img-sgx/${PV}/k4.14" | ||
24 | |||
25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH} \ | ||
26 | file://0001-srvkm-env-linux-osfunc.c-fix-gcc8-stringop-truncatio.patch \ | ||
27 | file://0001-buildvars.mk-pass-Wno-cast-function-type.patch" | ||
28 | |||
29 | S = "${WORKDIR}/git" | ||
30 | |||
31 | SRCREV = "76da7d73976f0a5dc04fdc84a3af899d6c2b1fe2" | ||
32 | |||
33 | TARGET_PRODUCT_omap-a15 = "jacinto6evm" | ||
34 | TARGET_PRODUCT_ti33x = "ti335x" | ||
35 | TARGET_PRODUCT_ti43x = "ti437x" | ||
36 | |||
37 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT}' | ||
38 | |||
39 | do_compile_prepend() { | ||
40 | cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux | ||
41 | } | ||
42 | |||
43 | do_install() { | ||
44 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary2_omap_linux_release/target/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install | ||
45 | } | ||