diff options
author | e-ruei1@ti.com <e-ruei1@ti.com> | 2018-07-14 02:54:09 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-07-28 05:09:22 +0000 |
commit | 1f81816c48c06ca749218b1eb9ad4e11d7d02691 (patch) | |
tree | 9e4843dcb389993e840ad2ec2aeab7556862ed50 /recipes-bsp/powervr-drivers | |
parent | b8d926c4dc0298b3921669470b13646a0e610a72 (diff) | |
download | meta-ti-1f81816c48c06ca749218b1eb9ad4e11d7d02691.tar.gz |
ti-sgx-ddk-km: add k3 (AM654x) support
- add K3 (AM654x) support based on SGX DDK 1.17
Signed-off-by: Eric Ruei <e-ruei1@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers')
-rw-r--r-- | recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb new file mode 100644 index 00000000..59310575 --- /dev/null +++ b/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs" | ||
2 | HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux" | ||
3 | LICENSE = "MIT | GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12" | ||
5 | |||
6 | inherit module | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k3" | ||
9 | |||
10 | MACHINE_KERNEL_PR_append = "o" | ||
11 | PR = "${MACHINE_KERNEL_PR}" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | DEPENDS = "virtual/kernel" | ||
16 | |||
17 | PROVIDES = "omapdrm-pvr" | ||
18 | |||
19 | RPROVIDES_${PN} = "omapdrm-pvr" | ||
20 | RREPLACES_${PN} = "omapdrm-pvr" | ||
21 | RCONFLICTS_${PN} = "omapdrm-pvr" | ||
22 | |||
23 | BRANCH = "ti-img-sgx/${PV}/k4.14" | ||
24 | |||
25 | SRC_URI = "git://git.ti.com/graphics/omap5-sgx-ddk-linux.git;protocol=git;branch=${BRANCH}" | ||
26 | |||
27 | S = "${WORKDIR}/git" | ||
28 | |||
29 | SRCREV = "b630d462f5fbb86e5f98965ba1af35da1207822f" | ||
30 | |||
31 | TARGET_PRODUCT_k3 = "ti654x" | ||
32 | |||
33 | EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=nulldrmws' | ||
34 | |||
35 | do_compile_prepend() { | ||
36 | cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux | ||
37 | } | ||
38 | |||
39 | do_install() { | ||
40 | make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B}/eurasia_km/eurasiacon/binary_omap_linux_nulldrmws_release/target_aarch64/kbuild INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install | ||
41 | } | ||