summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-03-30 17:41:49 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-04-06 18:46:00 -0400
commitf59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca (patch)
tree247fd11e0b217963fd0a6e6aa061bc0f35248532 /recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
parentc6d2bd9547ad46577c0d4ca9df7e1f8ab75f2a78 (diff)
downloadmeta-ti-f59d1e8ade4c685bc61abb5705d6e20ae7e6f7ca.tar.gz
omap3-sgx-modules: Install via the kernel's "modules_install" target.
* This allows the modules to have a consistent installation structure when directly building from source. * Previously, these modules would be manualy installed to appears as in-tree modules. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb')
-rw-r--r--recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb14
1 files changed, 2 insertions, 12 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
index 6a07d4f8..cf042fcd 100644
--- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
+++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_5.01.01.02.bb
@@ -10,7 +10,7 @@ IMGPV = "1.10.2359475"
10 10
11inherit module 11inherit module
12 12
13MACHINE_KERNEL_PR_append = "a" 13MACHINE_KERNEL_PR_append = "b"
14PR = "${MACHINE_KERNEL_PR}" 14PR = "${MACHINE_KERNEL_PR}"
15 15
16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin" 16BINFILE_HARDFP = "Graphics_SDK_setuplinux_hardfp_${SGXPV}.bin"
@@ -51,18 +51,8 @@ TI_PLATFORM_ti816x = "ti81xx"
51TI_PLATFORM_ti33x = "ti335x" 51TI_PLATFORM_ti33x = "ti335x"
52TI_PLATFORM_ti43x = "ti43xx" 52TI_PLATFORM_ti43x = "ti43xx"
53 53
54MODULESLOCATION_omap3 = "dc_omapfb3_linux"
55MODULESLOCATION_ti814x = "dc_ti81xx_linux"
56MODULESLOCATION_ti816x = "dc_ti81xx_linux"
57MODULESLOCATION_ti33x = "dc_ti335x_linux"
58MODULESLOCATION_ti43x = "dc_ti43xx_linux"
59
60MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}" 54MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=${TI_PLATFORM} SUPPORT_XORG=${SUPPORT_XORG}"
61 55
62do_install() { 56do_install() {
63 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr 57 make -C ${STAGING_KERNEL_DIR} SUBDIRS=${B} INSTALL_MOD_PATH=${D} PREFIX=${STAGING_DIR_HOST} modules_install
64 cp ${S}/pvrsrvkm.ko \
65 ${S}/services4/3rdparty/${MODULESLOCATION}/omaplfb.ko \
66 ${S}/services4/3rdparty/bufferclass_ti/bufferclass_ti.ko \
67 ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/gpu/pvr
68} 58}