summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pa-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-12-19 05:38:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-18 18:33:34 -0500
commit838c9edd2e6afe778ce49e32dd9c23c5985eefb8 (patch)
treec716ea8d89e04474c565ba3da988ac80408e6166 /recipes-bsp/pa-lld
parentbd65d9994ea25c6c222d61f0846b0fce7f7fa777 (diff)
downloadmeta-ti-838c9edd2e6afe778ce49e32dd9c23c5985eefb8.tar.gz
pa-lld: Add recipes for PA low level driver and test code
- Provides low level driver for Packet accelerator module - Supports k2h, k2k, k2l & k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pa-lld')
-rw-r--r--recipes-bsp/pa-lld/pa-lld-test_git.bb28
-rw-r--r--recipes-bsp/pa-lld/pa-lld.inc15
-rw-r--r--recipes-bsp/pa-lld/pa-lld_git.bb15
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld-test_git.bb b/recipes-bsp/pa-lld/pa-lld-test_git.bb
new file mode 100644
index 00000000..b70daddf
--- /dev/null
+++ b/recipes-bsp/pa-lld/pa-lld-test_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "TI PA LLD unit test and example binaries"
2
3DEPENDS = "common-csl-ip pa-lld cppi-lld qmss-lld sa-lld"
4
5include pa-lld.inc
6
7DEVICELIST = "k2h k2k k2l k2e"
8
9CHOICELIST = "yes no"
10
11do_compile () {
12# Now build the lld unit test examples
13 for device in ${DEVICELIST}
14 do
15 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S}
16 for choice in ${CHOICELIST}
17 do
18 make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
19 done
20 done
21}
22
23do_install () {
24 for device in ${DEVICELIST}
25 do
26 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" PA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
27 done
28}
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc
new file mode 100644
index 00000000..e93ce152
--- /dev/null
+++ b/recipes-bsp/pa-lld/pa-lld.inc
@@ -0,0 +1,15 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/pa/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
3
4COMPATIBLE_MACHINE = "keystone"
5
6BRANCH = "master"
7SRC_URI = "git://git.ti.com/keystone-rtos/pa-lld.git;destsuffix=git/ti/drv/pa;protocol=git;branch=${BRANCH}"
8
9# Below Commit ID corresponds to "DEV.PA_LLD.03.00.01.01"
10SRCREV = "55207930b4491f33776f2c4c2c0707a73c69314c"
11PV = "03.00.01.01"
12PR = "r0"
13
14BASEDIR = "${WORKDIR}/git"
15S = "${BASEDIR}/ti/drv/pa"
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb
new file mode 100644
index 00000000..63e34add
--- /dev/null
+++ b/recipes-bsp/pa-lld/pa-lld_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "TI PA LLD library"
2
3DEPENDS = "common-csl-ip rm-lld"
4
5include pa-lld.inc
6
7do_compile () {
8# Now build the lld in the updated directory
9 make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
10 make -f makefile_armv7 DEVICE=k2l lib PDK_INSTALL_PATH=${STAGING_INCDIR}
11}
12
13do_install () {
14 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
15}