diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-10-22 10:00:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-22 12:58:37 -0400 |
commit | ff68b5f5f4c1101ce207fe3b6708a61bc461177b (patch) | |
tree | cc1680824610bd02fa53f5d194ecd13cb2fc0403 /recipes-bsp/pa-lld | |
parent | 7beba2b8a292fc868f816a96243c9b36287f804f (diff) | |
download | meta-ti-ff68b5f5f4c1101ce207fe3b6708a61bc461177b.tar.gz |
pa-lld: Update to new version 3.0.1.5
- Add script to create device independent symbolic link to actual
device library
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pa-lld')
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld_git.bb | 13 |
2 files changed, 16 insertions, 3 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc index 7d922fb6..b8ade647 100644 --- a/recipes-bsp/pa-lld/pa-lld.inc +++ b/recipes-bsp/pa-lld/pa-lld.inc | |||
@@ -6,9 +6,9 @@ COMPATIBLE_MACHINE = "keystone" | |||
6 | BRANCH = "master" | 6 | BRANCH = "master" |
7 | SRC_URI = "git://git.ti.com/keystone-rtos/pa-lld.git;destsuffix=git/ti/drv/pa;protocol=git;branch=${BRANCH}" | 7 | SRC_URI = "git://git.ti.com/keystone-rtos/pa-lld.git;destsuffix=git/ti/drv/pa;protocol=git;branch=${BRANCH}" |
8 | 8 | ||
9 | # Below Commit ID corresponds to "DEV.PA_LLD.03.00.01.04" | 9 | # Below Commit ID corresponds to "DEV.PA_LLD.03.00.01.05A" |
10 | SRCREV = "92de8879be3712af684bd031ca0ed291c05d6050" | 10 | SRCREV = "ae3aa3e80ecf64fe5a16515d134a6bc217220e2e" |
11 | PV = "03.00.01.04" | 11 | PV = "03.00.01.05" |
12 | PR = "r1" | 12 | PR = "r1" |
13 | 13 | ||
14 | BASEDIR = "${WORKDIR}/git" | 14 | BASEDIR = "${WORKDIR}/git" |
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb index 63e34add..468113b2 100644 --- a/recipes-bsp/pa-lld/pa-lld_git.bb +++ b/recipes-bsp/pa-lld/pa-lld_git.bb | |||
@@ -4,6 +4,13 @@ DEPENDS = "common-csl-ip rm-lld" | |||
4 | 4 | ||
5 | include pa-lld.inc | 5 | include pa-lld.inc |
6 | 6 | ||
7 | SRC_URI += "file://init_pa.sh" | ||
8 | |||
9 | inherit update-rc.d | ||
10 | |||
11 | INITSCRIPT_NAME = "init_pa.sh" | ||
12 | INITSCRIPT_PARAMS = "defaults 10" | ||
13 | |||
7 | do_compile () { | 14 | do_compile () { |
8 | # Now build the lld in the updated directory | 15 | # Now build the lld in the updated directory |
9 | make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} | 16 | make -f makefile_armv7 DEVICE=k2h clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} |
@@ -12,4 +19,10 @@ do_compile () { | |||
12 | 19 | ||
13 | do_install () { | 20 | do_install () { |
14 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 21 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
22 | # Set the generic device library symbolic link | ||
23 | ln -sf libpa.so.1.0.0 ${D}${libdir}/libpa_device.so.1 | ||
24 | ln -sf libpa_device.so.1 ${D}${libdir}/libpa_device.so | ||
25 | # Copy init scripts | ||
26 | install -d ${D}${sysconfdir}/init.d/ | ||
27 | install -c -m 755 ${WORKDIR}/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
15 | } | 28 | } |