diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:22 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:59:32 -0500 |
commit | 51c651cf8c7d8ec33ab6b50feee41680fbb87281 (patch) | |
tree | 3a3d2ef73f50e0dc7cda35e30084f853a5d8a80c /recipes-bsp/pa-lld | |
parent | 092e391b81f52e3aa0c0cb7a42fd9010490b196e (diff) | |
download | meta-ti-51c651cf8c7d8ec33ab6b50feee41680fbb87281.tar.gz |
pa-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pa-lld')
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld.inc | 18 | ||||
-rw-r--r-- | recipes-bsp/pa-lld/pa-lld_git.bb | 2 |
3 files changed, 16 insertions, 6 deletions
diff --git a/recipes-bsp/pa-lld/pa-lld-test_git.bb b/recipes-bsp/pa-lld/pa-lld-test_git.bb index b70daddf..0fb6f079 100644 --- a/recipes-bsp/pa-lld/pa-lld-test_git.bb +++ b/recipes-bsp/pa-lld/pa-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip pa-lld cppi-lld qmss-lld sa-lld" | |||
4 | 4 | ||
5 | include pa-lld.inc | 5 | include pa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | DEVICELIST = "k2h k2k k2l k2e" | 9 | DEVICELIST = "k2h k2k k2l k2e" |
8 | 10 | ||
9 | CHOICELIST = "yes no" | 11 | CHOICELIST = "yes no" |
diff --git a/recipes-bsp/pa-lld/pa-lld.inc b/recipes-bsp/pa-lld/pa-lld.inc index b8ade647..58f0f424 100644 --- a/recipes-bsp/pa-lld/pa-lld.inc +++ b/recipes-bsp/pa-lld/pa-lld.inc | |||
@@ -3,13 +3,19 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/pa/COPYING.txt;md5=e8f6789acdcd | |||
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "keystone" | 4 | COMPATIBLE_MACHINE = "keystone" |
5 | 5 | ||
6 | BRANCH = "master" | 6 | PA_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pa-lld.git" |
7 | SRC_URI = "git://git.ti.com/keystone-rtos/pa-lld.git;destsuffix=git/ti/drv/pa;protocol=git;branch=${BRANCH}" | 7 | PA_LLD_GIT_PROTOCOL = "git" |
8 | PA_LLD_GIT_BRANCH = "master" | ||
9 | PA_LLD_GIT_DESTSUFFIX = "git/ti/drv/pa" | ||
8 | 10 | ||
9 | # Below Commit ID corresponds to "DEV.PA_LLD.03.00.01.05A" | 11 | # Below Commit ID corresponds to "DEV.PA_LLD.03.00.01.05A" |
10 | SRCREV = "ae3aa3e80ecf64fe5a16515d134a6bc217220e2e" | 12 | PA_LLD_SRCREV = "ae3aa3e80ecf64fe5a16515d134a6bc217220e2e" |
13 | |||
14 | BRANCH = "${PA_LLD_GIT_BRANCH}" | ||
15 | SRC_URI = "${PA_LLD_GIT_URI};destsuffix=${PA_LLD_GIT_DESTSUFFIX};protocol=${PA_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
16 | SRCREV = "${PA_LLD_SRCREV}" | ||
17 | |||
11 | PV = "03.00.01.05" | 18 | PV = "03.00.01.05" |
12 | PR = "r1" | 19 | INC_PR = "r2" |
13 | 20 | ||
14 | BASEDIR = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/${PA_LLD_GIT_DESTSUFFIX}" |
15 | S = "${BASEDIR}/ti/drv/pa" | ||
diff --git a/recipes-bsp/pa-lld/pa-lld_git.bb b/recipes-bsp/pa-lld/pa-lld_git.bb index 468113b2..0cb3bc50 100644 --- a/recipes-bsp/pa-lld/pa-lld_git.bb +++ b/recipes-bsp/pa-lld/pa-lld_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip rm-lld" | |||
4 | 4 | ||
5 | include pa-lld.inc | 5 | include pa-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | SRC_URI += "file://init_pa.sh" | 9 | SRC_URI += "file://init_pa.sh" |
8 | 10 | ||
9 | inherit update-rc.d | 11 | inherit update-rc.d |