summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2017-05-08 19:54:22 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-05-08 15:06:40 -0400
commitd3243e66eed682cc2d807dcd42be0f2b1f4dca7c (patch)
treece815739e6d815b4b860bbd447e87108d7f6acac /recipes-bsp/osal
parent633a01336103f5b93e65b2fcdaa9d72f088d2189 (diff)
downloadmeta-ti-d3243e66eed682cc2d807dcd42be0f2b1f4dca7c.tar.gz
osal: utilize oe_runmake
* Use the oe_runmake wrapper to invoke make * Supply common make arguments to EXTRA_OEMAKE such as which makefile to invoke. * This resolves build issues when osal needs to be reconfigured as do_configure would make the clean target of the incorrect makefile. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r--recipes-bsp/osal/osal-test_git.bb10
-rw-r--r--recipes-bsp/osal/osal_git.bb10
2 files changed, 12 insertions, 8 deletions
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb
index 9d4fa6d3..58156e3b 100644
--- a/recipes-bsp/osal/osal-test_git.bb
+++ b/recipes-bsp/osal/osal-test_git.bb
@@ -4,17 +4,19 @@ DEPENDS="common-csl-ip osal"
4 4
5include osal.inc 5include osal.inc
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8 8
9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" 9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
10 10
11EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}"
12
11do_compile () { 13do_compile () {
12# Build the tests 14# Build the tests
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} 15 oe_runmake clean
14 make -f makefile_armv7 tests PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S} 16 oe_runmake tests
15} 17}
16 18
17do_install () { 19do_install () {
18# Install the binary 20# Install the binary
19 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_BIN_BASE_DIR=${D}${bindir} OSAL_SRC_DIR=${S} 21 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir}
20} 22}
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb
index ecb46b22..bb30ab5a 100644
--- a/recipes-bsp/osal/osal_git.bb
+++ b/recipes-bsp/osal/osal_git.bb
@@ -4,17 +4,19 @@ DEPENDS="common-csl-ip"
4 4
5include osal.inc 5include osal.inc
6 6
7PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
8 8
9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" 9S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
10 10
11EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
12
11do_compile () { 13do_compile () {
12# Build the lib 14# Build the lib
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} 15 oe_runmake clean
14 make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} 16 oe_runmake lib
15} 17}
16 18
17do_install () { 19do_install () {
18# Install the lib 20# Install the lib
19 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 21 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
20} 22}