diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2019-11-15 21:14:41 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-12-09 18:15:23 +0000 |
commit | 73c1b85d89022aaf1ee814249c3894823572fa65 (patch) | |
tree | 653e809ae02459cd406a2bb22122d6e5124a0f52 /recipes-bsp/osal | |
parent | fbfd67d0d4bf8bf60d879e6e6e4093ac90c7c869 (diff) | |
download | meta-ti-73c1b85d89022aaf1ee814249c3894823572fa65.tar.gz |
osal: migrate to ti-pdk-fetch.bbclass
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r-- | recipes-bsp/osal/osal-rtos_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/osal/osal-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/osal/osal.inc | 14 | ||||
-rw-r--r-- | recipes-bsp/osal/osal_git.bb | 2 |
4 files changed, 4 insertions, 16 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb index 62d1f997..a718f7ca 100644 --- a/recipes-bsp/osal/osal-rtos_git.bb +++ b/recipes-bsp/osal/osal-rtos_git.bb | |||
@@ -5,8 +5,6 @@ PR = "${INC_PR}.0" | |||
5 | 5 | ||
6 | COMPATIBLE_MACHINE_append = "|c66x|k3" | 6 | COMPATIBLE_MACHINE_append = "|c66x|k3" |
7 | 7 | ||
8 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
9 | |||
10 | DEPENDS_append_ti33x = " starterware-rtos" | 8 | DEPENDS_append_ti33x = " starterware-rtos" |
11 | DEPENDS_append_ti43x = " starterware-rtos" | 9 | DEPENDS_append_ti43x = " starterware-rtos" |
12 | 10 | ||
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb index 58156e3b..354aa797 100644 --- a/recipes-bsp/osal/osal-test_git.bb +++ b/recipes-bsp/osal/osal-test_git.bb | |||
@@ -6,8 +6,6 @@ include osal.inc | |||
6 | 6 | ||
7 | PR = "${INC_PR}.1" | 7 | PR = "${INC_PR}.1" |
8 | 8 | ||
9 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
10 | |||
11 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S}" |
12 | 10 | ||
13 | do_compile () { | 11 | do_compile () { |
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc index b0b015c7..1f0a0778 100644 --- a/recipes-bsp/osal/osal.inc +++ b/recipes-bsp/osal/osal.inc | |||
@@ -4,17 +4,11 @@ LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=6fbde6922f8bca1e6cd | |||
4 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1" | 4 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1" |
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 5 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
6 | 6 | ||
7 | OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" | 7 | inherit ti-pdk-fetch |
8 | OSAL_GIT_PROTOCOL = "git" | ||
9 | OSAL_GIT_BRANCH = "master" | ||
10 | OSAL_GIT_DESTSUFFIX = "git/ti/osal" | ||
11 | 8 | ||
12 | # Below commit ID corresponding to "DEV.OSAL.01.00.00.16B" | 9 | TI_PDK_COMP = "ti.osal" |
13 | OSAL_SRCREV = "b78489d9d78d9366f1865aa847b743b1b29f6fd4" | ||
14 | 10 | ||
15 | BRANCH = "${OSAL_GIT_BRANCH}" | 11 | PE = "1" |
16 | SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}" | ||
17 | 12 | ||
18 | SRCREV = "${OSAL_SRCREV}" | ||
19 | PV = "01.00.00.16B" | ||
20 | INC_PR = "r0" | 13 | INC_PR = "r0" |
14 | |||
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb index 8f589376..4f881d2e 100644 --- a/recipes-bsp/osal/osal_git.bb +++ b/recipes-bsp/osal/osal_git.bb | |||
@@ -6,8 +6,6 @@ include osal.inc | |||
6 | 6 | ||
7 | PR = "${INC_PR}.1" | 7 | PR = "${INC_PR}.1" |
8 | 8 | ||
9 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
10 | |||
11 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" |
12 | 10 | ||
13 | do_compile () { | 11 | do_compile () { |