diff options
author | Justin Sobota <jsobota@ti.com> | 2016-12-15 21:54:39 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-12-19 18:14:04 -0500 |
commit | e5be57d13d7cbb42e95d360f3153ae796864ad8d (patch) | |
tree | 2b56b4063984c0cf26d168fb19b95564a9b29dc0 /recipes-bsp/osal | |
parent | 28bd12d2d73e4d21096e9a45e5cd03600e21cab5 (diff) | |
download | meta-ti-e5be57d13d7cbb42e95d360f3153ae796864ad8d.tar.gz |
osal: Upstream version 1.0.0.5E
Signed-off-by: Justin Sobota <jsobota@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/osal')
-rw-r--r-- | recipes-bsp/osal/osal-test_git.bb | 20 | ||||
-rw-r--r-- | recipes-bsp/osal/osal.inc | 20 | ||||
-rw-r--r-- | recipes-bsp/osal/osal_git.bb | 20 |
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-bsp/osal/osal-test_git.bb b/recipes-bsp/osal/osal-test_git.bb new file mode 100644 index 00000000..9d4fa6d3 --- /dev/null +++ b/recipes-bsp/osal/osal-test_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "TI OSAL tests" | ||
2 | |||
3 | DEPENDS="common-csl-ip osal" | ||
4 | |||
5 | include osal.inc | ||
6 | |||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
10 | |||
11 | do_compile () { | ||
12 | # Build the tests | ||
13 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
14 | make -f makefile_armv7 tests PDK_INSTALL_PATH=${STAGING_INCDIR} OSAL_SRC_DIR=${S} | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | # Install the binary | ||
19 | make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_BIN_BASE_DIR=${D}${bindir} OSAL_SRC_DIR=${S} | ||
20 | } | ||
diff --git a/recipes-bsp/osal/osal.inc b/recipes-bsp/osal/osal.inc new file mode 100644 index 00000000..55a165e3 --- /dev/null +++ b/recipes-bsp/osal/osal.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | LIC_FILES_CHKSUM = "file://osal.h;beginline=1;endline=31;md5=8cbd8efb1460e4f16e6b00c8a7686be4" | ||
3 | |||
4 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone" | ||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
7 | OSAL_GIT_URI = "git://git.ti.com/keystone-rtos/osal.git" | ||
8 | OSAL_GIT_PROTOCOL = "git" | ||
9 | OSAL_GIT_BRANCH = "master" | ||
10 | OSAL_GIT_DESTSUFFIX = "git/ti/osal" | ||
11 | |||
12 | # Below commit ID corresponds to "DEV.OSAL.01.00.00.05E" | ||
13 | OSAL_SRCREV = "5125c71d756530513500b463d3301d03dee04497" | ||
14 | |||
15 | BRANCH = "${OSAL_GIT_BRANCH}" | ||
16 | SRC_URI = "${OSAL_GIT_URI};destsuffix=${OSAL_GIT_DESTSUFFIX};protocol=${OSAL_GIT_PROTOCOL};branch=${BRANCH}" | ||
17 | |||
18 | SRCREV = "${OSAL_SRCREV}" | ||
19 | PV = "01.00.00.05E" | ||
20 | INC_PR = "r0" | ||
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb new file mode 100644 index 00000000..ecb46b22 --- /dev/null +++ b/recipes-bsp/osal/osal_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "TI OSAL library for Linux" | ||
2 | |||
3 | DEPENDS="common-csl-ip" | ||
4 | |||
5 | include osal.inc | ||
6 | |||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}" | ||
10 | |||
11 | do_compile () { | ||
12 | # Build the lib | ||
13 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
14 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | # Install the lib | ||
19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
20 | } | ||