summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal/osal_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2022-02-22 04:13:08 +0000
committerRyan Eatmon <reatmon@ti.com>2022-02-22 12:01:31 -0600
commit53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd (patch)
tree2d7a22adf169476666eda7d988767506f40f3d20 /recipes-bsp/osal/osal_git.bb
parentdd558151806beb2ac95356a7a8275498ccddf125 (diff)
downloadmeta-ti-53f4cdf2ce35cbb0aaac0891e5f06e8909caecdd.tar.gz
classes,recipes: remove K1/2 PDK RTOS support, FWs and IPC transports
Remove deprecated support for compiling Keystone1/2 RTOS components and Linux firmwares using PDK, CSL, etc. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp/osal/osal_git.bb')
-rw-r--r--recipes-bsp/osal/osal_git.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/recipes-bsp/osal/osal_git.bb b/recipes-bsp/osal/osal_git.bb
deleted file mode 100644
index 4f881d2e..00000000
--- a/recipes-bsp/osal/osal_git.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1DESCRIPTION = "TI OSAL library for Linux"
2
3DEPENDS="common-csl-ip"
4
5include osal.inc
6
7PR = "${INC_PR}.1"
8
9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
10
11do_compile () {
12# Build the lib
13 oe_runmake clean
14 oe_runmake lib
15}
16
17do_install () {
18# Install the lib
19 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
20 chown -R root:root ${D}
21}