summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/osal/osal-rtos_git.bb
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-01 02:40:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-07-12 14:09:06 -0400
commite4639170fbf27204aa6f62052e73c5bbacf275e7 (patch)
tree3e9fe8977356642bc503762f2b8a20804259262c /recipes-bsp/osal/osal-rtos_git.bb
parentfd6dbc2945cf27d49c08752c3c79fe862aab5660 (diff)
downloadmeta-ti-e4639170fbf27204aa6f62052e73c5bbacf275e7.tar.gz
osal: Added rtos recipe and updated to 1.0.0.7 along with omapl1 support
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/osal/osal-rtos_git.bb')
-rw-r--r--recipes-bsp/osal/osal-rtos_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/osal/osal-rtos_git.bb b/recipes-bsp/osal/osal-rtos_git.bb
new file mode 100644
index 00000000..da421b61
--- /dev/null
+++ b/recipes-bsp/osal/osal-rtos_git.bb
@@ -0,0 +1,18 @@
1inherit ti-pdk
2require recipes-bsp/osal/osal.inc
3
4PR = "${INC_PR}.0"
5
6S = "${WORKDIR}/${OSAL_GIT_DESTSUFFIX}"
7
8DEPENDS_append_ti33x = " starterware-rtos"
9DEPENDS_append_ti43x = " starterware-rtos"
10
11# Build with make instead of XDC
12TI_PDK_XDCMAKE = "0"
13
14export PDK_OSAL_ROOT_PATH ="${WORKDIR}/build"
15export DEST_ROOT="${S}"
16
17# HTML doc link params
18PDK_COMP_LINK_TEXT = "OSAL Library"