diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:18 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:59:16 -0500 |
commit | ba5a045f85afc3e510170a038ef4d55bce505bd7 (patch) | |
tree | 529bf2c4237a2b556ad79423b1095a6583b31158 /recipes-bsp/mmap-lld | |
parent | dc2dab062d1f12eab51ee8aae793ff7cdbcee2ac (diff) | |
download | meta-ti-ba5a045f85afc3e510170a038ef4d55bce505bd7.tar.gz |
mmap-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/mmap-lld')
-rw-r--r-- | recipes-bsp/mmap-lld/mmap-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/mmap-lld/mmap-lld.inc | 15 | ||||
-rw-r--r-- | recipes-bsp/mmap-lld/mmap-lld_git.bb | 2 |
3 files changed, 15 insertions, 4 deletions
diff --git a/recipes-bsp/mmap-lld/mmap-lld-test_git.bb b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb index 41e46f7c..06173766 100644 --- a/recipes-bsp/mmap-lld/mmap-lld-test_git.bb +++ b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb | |||
@@ -1,6 +1,8 @@ | |||
1 | DESCRIPTION = "TI KEYSTONE MMAP driver test binaries " | 1 | DESCRIPTION = "TI KEYSTONE MMAP driver test binaries " |
2 | include mmap-lld.inc | 2 | include mmap-lld.inc |
3 | 3 | ||
4 | PR = "${INC_PR}.0" | ||
5 | |||
4 | DEPENDS="common-csl-ip mmap-lld" | 6 | DEPENDS="common-csl-ip mmap-lld" |
5 | RDEPENDS_${PN}="uio-module-drv" | 7 | RDEPENDS_${PN}="uio-module-drv" |
6 | 8 | ||
diff --git a/recipes-bsp/mmap-lld/mmap-lld.inc b/recipes-bsp/mmap-lld/mmap-lld.inc index a5158d51..cde0fecc 100644 --- a/recipes-bsp/mmap-lld/mmap-lld.inc +++ b/recipes-bsp/mmap-lld/mmap-lld.inc | |||
@@ -4,12 +4,19 @@ COMPATIBLE_MACHINE = "keystone" | |||
4 | 4 | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b3315b8190036fe1c6a8263d02e15606" | 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b3315b8190036fe1c6a8263d02e15606" |
6 | 6 | ||
7 | BRANCH="master" | 7 | MMAP_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/mmap-lld.git" |
8 | SRC_URI = "git://git.ti.com/keystone-rtos/mmap-lld.git;destsuffix=git/ti/runtime/mmap;protocol=git;branch=${BRANCH}" | 8 | MMAP_LLD_GIT_PROTOCOL = "git" |
9 | MMAP_LLD_GIT_BRANCH = "master" | ||
10 | MMAP_LLD_GIT_DESTSUFFIX = "git/ti/runtime/mmap" | ||
11 | |||
9 | # Commit correspond to DEV.MMAP.02.00.00.04 | 12 | # Commit correspond to DEV.MMAP.02.00.00.04 |
10 | SRCREV = "306895eb2d5decd14a760e70d273946958ff716f" | 13 | MMAP_LLD_SRCREV = "306895eb2d5decd14a760e70d273946958ff716f" |
14 | |||
15 | BRANCH="${MMAP_LLD_GIT_BRANCH}" | ||
16 | SRC_URI = "${MMAP_LLD_GIT_URI};destsuffix=${MMAP_LLD_GIT_DESTSUFFIX};protocol=${MMAP_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
17 | SRCREV = "${MMAP_LLD_SRCREV}" | ||
11 | 18 | ||
12 | PV = "2.0.0.4" | 19 | PV = "2.0.0.4" |
13 | PR = "r1" | 20 | INC_PR = "r2" |
14 | 21 | ||
15 | S = "${WORKDIR}/git/ti/runtime/mmap" | 22 | S = "${WORKDIR}/git/ti/runtime/mmap" |
diff --git a/recipes-bsp/mmap-lld/mmap-lld_git.bb b/recipes-bsp/mmap-lld/mmap-lld_git.bb index 3a56a620..1cfc90fb 100644 --- a/recipes-bsp/mmap-lld/mmap-lld_git.bb +++ b/recipes-bsp/mmap-lld/mmap-lld_git.bb | |||
@@ -1,6 +1,8 @@ | |||
1 | DESCRIPTION = "TI KEYSTONE mmap driver using Keystone MPAX Programming" | 1 | DESCRIPTION = "TI KEYSTONE mmap driver using Keystone MPAX Programming" |
2 | include mmap-lld.inc | 2 | include mmap-lld.inc |
3 | 3 | ||
4 | PR = "${INC_PR}.0" | ||
5 | |||
4 | DEPENDS="common-csl-ip" | 6 | DEPENDS="common-csl-ip" |
5 | 7 | ||
6 | do_compile () { | 8 | do_compile () { |