summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/mmap-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-11-19 17:47:01 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-15 15:00:33 -0500
commitf81589410d96d123b6143d1bc8e33374775e7d7c (patch)
tree04049523202c8d4a3ff7199584374815c0cc64bc /recipes-bsp/mmap-lld
parent977e53ebc9dfbbbdc154d771ceb9ce39bed7775a (diff)
downloadmeta-ti-f81589410d96d123b6143d1bc8e33374775e7d7c.tar.gz
mmap-lld; Add new recipe for mmap lld
- Provides memory map driver using Keystone MPAX module - Test recipe is used to build test binaries using the mmap lld library - Supports k2h, k2k & k2e Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/mmap-lld')
-rwxr-xr-xrecipes-bsp/mmap-lld/mmap-lld-test_git.bb40
-rw-r--r--recipes-bsp/mmap-lld/mmap-lld.inc16
-rwxr-xr-xrecipes-bsp/mmap-lld/mmap-lld_git.bb12
3 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/mmap-lld/mmap-lld-test_git.bb b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb
new file mode 100755
index 00000000..41e46f7c
--- /dev/null
+++ b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "TI KEYSTONE MMAP driver test binaries "
2include mmap-lld.inc
3
4DEPENDS="common-csl-ip mmap-lld"
5RDEPENDS_${PN}="uio-module-drv"
6
7DEVICELIST = "k2h \
8 k2k \
9 k2e \
10"
11
12CHOICELIST = " yes \
13 no \
14"
15
16do_compile () {
17 for device in ${DEVICELIST}
18 do
19 make -f makefile_armv7 clean \
20 PDK_INSTALL_PATH="${STAGING_INCDIR}" \
21 DEVICE="$device" MPAX_SRC_DIR="${S}"
22 for choice in ${CHOICELIST}
23 do
24 make -f makefile_armv7 tests examples \
25 PDK_INSTALL_PATH=${STAGING_INCDIR} \
26 DEVICE="$device" MPAX_SRC_DIR="${S}" \
27 USEDYNAMIC_LIB="$choice"
28 done
29 done
30}
31
32do_install () {
33 for device in ${DEVICELIST}
34 do
35 make -f makefile_armv7 installbin \
36 PDK_INSTALL_PATH=${STAGING_INCDIR} \
37 DEVICE="$device" MPAX_SRC_DIR="${S}" \
38 INSTALL_BIN_BASE_DIR="${D}/${bindir}"
39 done
40}
diff --git a/recipes-bsp/mmap-lld/mmap-lld.inc b/recipes-bsp/mmap-lld/mmap-lld.inc
new file mode 100644
index 00000000..b8a5b324
--- /dev/null
+++ b/recipes-bsp/mmap-lld/mmap-lld.inc
@@ -0,0 +1,16 @@
1LICENSE = "BSD-3-Clause"
2
3COMPATIBLE_MACHINE = "keystone"
4
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=b3315b8190036fe1c6a8263d02e15606"
6
7
8BRANCH="master"
9SRC_URI = "git://git.ti.com/keystone-rtos/mmap-lld.git;destsuffix=git/ti/runtime/mmap;protocol=git;branch=${BRANCH}"
10# Commit correspond to DEV.MMAP.02.00.00.03
11SRCREV = "601f9284c392f67bb7f69ed1a5df5231a43c3137"
12
13PV="2.0.0"
14PR = "r0"
15
16S = "${WORKDIR}/git/ti/runtime/mmap" \ No newline at end of file
diff --git a/recipes-bsp/mmap-lld/mmap-lld_git.bb b/recipes-bsp/mmap-lld/mmap-lld_git.bb
new file mode 100755
index 00000000..3a56a620
--- /dev/null
+++ b/recipes-bsp/mmap-lld/mmap-lld_git.bb
@@ -0,0 +1,12 @@
1DESCRIPTION = "TI KEYSTONE mmap driver using Keystone MPAX Programming"
2include mmap-lld.inc
3
4DEPENDS="common-csl-ip"
5
6do_compile () {
7 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR}
8}
9
10do_install () {
11 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
12}