diff options
author | Sam Nelson <sam.nelson@ti.com> | 2014-11-19 17:47:01 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-12-15 15:00:33 -0500 |
commit | f81589410d96d123b6143d1bc8e33374775e7d7c (patch) | |
tree | 04049523202c8d4a3ff7199584374815c0cc64bc /recipes-bsp/mmap-lld/mmap-lld-test_git.bb | |
parent | 977e53ebc9dfbbbdc154d771ceb9ce39bed7775a (diff) | |
download | meta-ti-f81589410d96d123b6143d1bc8e33374775e7d7c.tar.gz |
mmap-lld; Add new recipe for mmap lld
- Provides memory map driver using Keystone MPAX module
- Test recipe is used to build test binaries using the mmap lld library
- Supports k2h, k2k & k2e
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/mmap-lld/mmap-lld-test_git.bb')
-rwxr-xr-x | recipes-bsp/mmap-lld/mmap-lld-test_git.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-bsp/mmap-lld/mmap-lld-test_git.bb b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb new file mode 100755 index 00000000..41e46f7c --- /dev/null +++ b/recipes-bsp/mmap-lld/mmap-lld-test_git.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | DESCRIPTION = "TI KEYSTONE MMAP driver test binaries " | ||
2 | include mmap-lld.inc | ||
3 | |||
4 | DEPENDS="common-csl-ip mmap-lld" | ||
5 | RDEPENDS_${PN}="uio-module-drv" | ||
6 | |||
7 | DEVICELIST = "k2h \ | ||
8 | k2k \ | ||
9 | k2e \ | ||
10 | " | ||
11 | |||
12 | CHOICELIST = " yes \ | ||
13 | no \ | ||
14 | " | ||
15 | |||
16 | do_compile () { | ||
17 | for device in ${DEVICELIST} | ||
18 | do | ||
19 | make -f makefile_armv7 clean \ | ||
20 | PDK_INSTALL_PATH="${STAGING_INCDIR}" \ | ||
21 | DEVICE="$device" MPAX_SRC_DIR="${S}" | ||
22 | for choice in ${CHOICELIST} | ||
23 | do | ||
24 | make -f makefile_armv7 tests examples \ | ||
25 | PDK_INSTALL_PATH=${STAGING_INCDIR} \ | ||
26 | DEVICE="$device" MPAX_SRC_DIR="${S}" \ | ||
27 | USEDYNAMIC_LIB="$choice" | ||
28 | done | ||
29 | done | ||
30 | } | ||
31 | |||
32 | do_install () { | ||
33 | for device in ${DEVICELIST} | ||
34 | do | ||
35 | make -f makefile_armv7 installbin \ | ||
36 | PDK_INSTALL_PATH=${STAGING_INCDIR} \ | ||
37 | DEVICE="$device" MPAX_SRC_DIR="${S}" \ | ||
38 | INSTALL_BIN_BASE_DIR="${D}/${bindir}" | ||
39 | done | ||
40 | } | ||