diff options
author | Ivan Pang <i-pang@ti.com> | 2017-08-01 11:45:05 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:04:29 -0400 |
commit | d44d83fd8d540f163fb70297b1cf3d2947ffb393 (patch) | |
tree | 06b776479731c0a9a3b2e6d74539fc6b03e91b4a /recipes-bsp/mad-utils/mad-utils-rtos_git.bb | |
parent | 62b190a82b899bccdd5f8a5f2af1d33739652708 (diff) | |
download | meta-ti-d44d83fd8d540f163fb70297b1cf3d2947ffb393.tar.gz |
mad-utils-rtos: added recipe for MAD utils
This recipe adds the Multicore Application Deployment (MAD) utility
for c665x-evm and c667x-evm.
Signed-off-by: Ivan Pang <i-pang@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/mad-utils/mad-utils-rtos_git.bb')
-rw-r--r-- | recipes-bsp/mad-utils/mad-utils-rtos_git.bb | 57 |
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes-bsp/mad-utils/mad-utils-rtos_git.bb b/recipes-bsp/mad-utils/mad-utils-rtos_git.bb new file mode 100644 index 00000000..0144aad2 --- /dev/null +++ b/recipes-bsp/mad-utils/mad-utils-rtos_git.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | SUMMARY = "Utility for loading and running multicore applications" | ||
2 | DESCRIPTION = "Multicore Application Deployment (MAD) utility is used \ | ||
3 | for loading and running a multicore application on an embedded \ | ||
4 | processor with multiple cores. This utility package contains the \ | ||
5 | scripts to combine multiple applications for different cores into a \ | ||
6 | single binary as well as loadable application to parse and execute the applications on different cores." | ||
7 | |||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://README.txt;md5=44b2180aec0657f6b0e42e5611c0bafb" | ||
10 | |||
11 | require recipes-ti/includes/ti-paths.inc | ||
12 | |||
13 | DEPENDS = "ti-cgt6x-7-native" | ||
14 | |||
15 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
16 | COMPATIBLE_MACHINE = "c66x" | ||
17 | |||
18 | BRANCH = "master" | ||
19 | SRC_URI = "git://git.ti.com/keystone-rtos/mad-utils.git;protocol=git;branch=${BRANCH}" | ||
20 | SRCREV = "2458510f76eddfa837c2b83448965e233156944b" | ||
21 | PR = "r0" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | export C6X_BASE_DIR="${TI_CGT6X_7_INSTALL_DIR}" | ||
26 | PATH_prepend = "${TI_CGT6X_7_INSTALL_DIR}/bin:" | ||
27 | |||
28 | DEVICE = "" | ||
29 | DEVICE_c665x-evm = "C6657" | ||
30 | DEVICE_c667x-evm = "C6678" | ||
31 | |||
32 | ENDIAN = "" | ||
33 | ENDIAN_c665x-evm = "little big" | ||
34 | ENDIAN_c667x-evm = "little big" | ||
35 | |||
36 | do_compile() { | ||
37 | cd mad-loader | ||
38 | for e in ${ENDIAN} | ||
39 | do | ||
40 | mkdir -p bin/${DEVICE}/${e} | ||
41 | make -C mal/malLib/build clean all DEVICE=${DEVICE} ENDIAN=${e} C_DIR=${C6X_BASE_DIR} | ||
42 | make -C mal/malApp/build clean all DEVICE=${DEVICE} ENDIAN=${e} C_DIR=${C6X_BASE_DIR} | ||
43 | cp mal/malApp/build/mal_app.exe bin/${DEVICE}/${e} | ||
44 | make -C nmlLoader/build clean all DEVICE=${DEVICE} ENDIAN=${e} C_DIR=${C6X_BASE_DIR} | ||
45 | cp nmlLoader/build/nml.exe bin/${DEVICE}/${e} | ||
46 | done | ||
47 | cd - | ||
48 | } | ||
49 | |||
50 | do_install() { | ||
51 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/mad-utils | ||
52 | cp -rP --preserve=mode,links,timestamps --no-preserve=ownership * ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/mad-utils | ||
53 | } | ||
54 | |||
55 | FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/boot/mad-utils" | ||
56 | |||
57 | INSANE_SKIP_${PN} += "arch staticdev ldflags file-rdeps" | ||