diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-02-11 03:28:08 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-02-19 16:45:32 -0500 |
commit | bfc42e6786167d6948bbceee7b82345738a960db (patch) | |
tree | ed272fd9c5cd7884e22182136b32183c6d7a387a /recipes-bsp/iqn2-lld | |
parent | ea65cbe1c9d448777658a877b41a928b9369e56c (diff) | |
download | meta-ti-bfc42e6786167d6948bbceee7b82345738a960db.tar.gz |
iqn2-lld: Add recipes for TI iqn2 peripheral module low level driver
- Provides low level driver for TI iqn2 peripheral module
- Supports k2l device
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/iqn2-lld')
-rw-r--r-- | recipes-bsp/iqn2-lld/iqn2-lld.inc | 13 | ||||
-rw-r--r-- | recipes-bsp/iqn2-lld/iqn2-lld_git.bb | 16 |
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld.inc b/recipes-bsp/iqn2-lld/iqn2-lld.inc new file mode 100644 index 00000000..c5b15116 --- /dev/null +++ b/recipes-bsp/iqn2-lld/iqn2-lld.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | |||
4 | BRANCH = "master" | ||
5 | SRC_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git;destsuffix=git/ti/drv/iqn2;protocol=git;branch=${BRANCH}" | ||
6 | # Following commit corresponds to DEV.IQN_LLD.01.00.00.05B | ||
7 | SRCREV = "ca35079f41d06259be39f992f55a9f815d305ef5" | ||
8 | |||
9 | PV = "1.0.0.5" | ||
10 | |||
11 | COMPATIBLE_MACHINE = "k2l-evm" | ||
12 | |||
13 | S = "${WORKDIR}/git/ti/drv/iqn2" | ||
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb new file mode 100644 index 00000000..19ffc053 --- /dev/null +++ b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "TI IQN2 peripheral module low level driver" | ||
2 | |||
3 | DEPENDS = "common-csl-ip" | ||
4 | |||
5 | include iqn2-lld.inc | ||
6 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | ||
8 | |||
9 | do_compile () { | ||
10 | oe_runmake clean | ||
11 | oe_runmake lib | ||
12 | } | ||
13 | |||
14 | do_install () { | ||
15 | oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
16 | } | ||