diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:17 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:59:12 -0500 |
commit | dc2dab062d1f12eab51ee8aae793ff7cdbcee2ac (patch) | |
tree | 21fff3e90143b0426cbb0efd1d75087b494592f0 /recipes-bsp/iqn2-lld | |
parent | f905be96ee3b8ca3298a11681df695994dad6657 (diff) | |
download | meta-ti-dc2dab062d1f12eab51ee8aae793ff7cdbcee2ac.tar.gz |
iqn2-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/iqn2-lld')
-rw-r--r-- | recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/iqn2-lld/iqn2-lld.inc | 16 | ||||
-rw-r--r-- | recipes-bsp/iqn2-lld/iqn2-lld_git.bb | 2 |
3 files changed, 16 insertions, 4 deletions
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb index f1aa9e4a..f276c4b3 100644 --- a/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb +++ b/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip iqn2-lld dfe-lld" | |||
4 | 4 | ||
5 | include iqn2-lld.inc | 5 | include iqn2-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} IQN2_SRC_DIR=${WORKDIR}/git" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} IQN2_SRC_DIR=${WORKDIR}/git" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld.inc b/recipes-bsp/iqn2-lld/iqn2-lld.inc index 812d3f61..4a43a266 100644 --- a/recipes-bsp/iqn2-lld/iqn2-lld.inc +++ b/recipes-bsp/iqn2-lld/iqn2-lld.inc | |||
@@ -1,13 +1,21 @@ | |||
1 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" | 1 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" |
2 | LICENSE = "BSD-3-Clause" | 2 | LICENSE = "BSD-3-Clause" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | IQN2_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git;destsuffix=git/ti/drv/iqn2;protocol=git;branch=${BRANCH}" | 5 | IQN2_LLD_GIT_PROTOCOL = "git" |
6 | IQN2_LLD_GIT_BRANCH = "master" | ||
7 | IQN2_LLD_GIT_DESTSUFFIX = "git/ti/drv/iqn2" | ||
8 | |||
6 | # Following commit corresponds to DEV.IQN_LLD.01.00.00.08F | 9 | # Following commit corresponds to DEV.IQN_LLD.01.00.00.08F |
7 | SRCREV = "29d5358b944f1447c024263f86e8c71784440b99" | 10 | IQN2_LLD_SRCREV = "29d5358b944f1447c024263f86e8c71784440b99" |
11 | |||
12 | BRANCH = "${IQN2_LLD_GIT_BRANCH}" | ||
13 | SRC_URI = "${IQN2_LLD_GIT_URI};destsuffix=${IQN2_LLD_GIT_DESTSUFFIX};protocol=${IQN2_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | SRCREV = "${IQN2_LLD_SRCREV}" | ||
8 | 15 | ||
9 | PV = "1.0.0.8" | 16 | PV = "1.0.0.8" |
17 | INC_PR = "r1" | ||
10 | 18 | ||
11 | COMPATIBLE_MACHINE = "k2l-evm" | 19 | COMPATIBLE_MACHINE = "k2l-evm" |
12 | 20 | ||
13 | S = "${WORKDIR}/git/ti/drv/iqn2" | 21 | S = "${WORKDIR}/${IQN2_LLD_GIT_DESTSUFFIX}" |
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb index 19ffc053..4e681169 100644 --- a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb +++ b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip" | |||
4 | 4 | ||
5 | include iqn2-lld.inc | 5 | include iqn2-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" | 9 | EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |