summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/iqn2-lld
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-11-04 01:47:17 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-04 09:59:12 -0500
commitdc2dab062d1f12eab51ee8aae793ff7cdbcee2ac (patch)
tree21fff3e90143b0426cbb0efd1d75087b494592f0 /recipes-bsp/iqn2-lld
parentf905be96ee3b8ca3298a11681df695994dad6657 (diff)
downloadmeta-ti-dc2dab062d1f12eab51ee8aae793ff7cdbcee2ac.tar.gz
iqn2-lld: Clean up recipes
* Use INC_PR to track recipe revisions * Define variables for GIT SRC_URI parameters Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/iqn2-lld')
-rw-r--r--recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb2
-rw-r--r--recipes-bsp/iqn2-lld/iqn2-lld.inc16
-rw-r--r--recipes-bsp/iqn2-lld/iqn2-lld_git.bb2
3 files changed, 16 insertions, 4 deletions
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb
index f1aa9e4a..f276c4b3 100644
--- a/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb
+++ b/recipes-bsp/iqn2-lld/iqn2-lld-test_git.bb
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip iqn2-lld dfe-lld"
4 4
5include iqn2-lld.inc 5include iqn2-lld.inc
6 6
7PR = "${INC_PR}.0"
8
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} IQN2_SRC_DIR=${WORKDIR}/git" 9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} IQN2_SRC_DIR=${WORKDIR}/git"
8 10
9do_compile () { 11do_compile () {
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld.inc b/recipes-bsp/iqn2-lld/iqn2-lld.inc
index 812d3f61..4a43a266 100644
--- a/recipes-bsp/iqn2-lld/iqn2-lld.inc
+++ b/recipes-bsp/iqn2-lld/iqn2-lld.inc
@@ -1,13 +1,21 @@
1LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea" 1LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea"
2LICENSE = "BSD-3-Clause" 2LICENSE = "BSD-3-Clause"
3 3
4BRANCH = "master" 4IQN2_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git"
5SRC_URI = "git://git.ti.com/keystone-rtos/iqn2-lld.git;destsuffix=git/ti/drv/iqn2;protocol=git;branch=${BRANCH}" 5IQN2_LLD_GIT_PROTOCOL = "git"
6IQN2_LLD_GIT_BRANCH = "master"
7IQN2_LLD_GIT_DESTSUFFIX = "git/ti/drv/iqn2"
8
6# Following commit corresponds to DEV.IQN_LLD.01.00.00.08F 9# Following commit corresponds to DEV.IQN_LLD.01.00.00.08F
7SRCREV = "29d5358b944f1447c024263f86e8c71784440b99" 10IQN2_LLD_SRCREV = "29d5358b944f1447c024263f86e8c71784440b99"
11
12BRANCH = "${IQN2_LLD_GIT_BRANCH}"
13SRC_URI = "${IQN2_LLD_GIT_URI};destsuffix=${IQN2_LLD_GIT_DESTSUFFIX};protocol=${IQN2_LLD_GIT_PROTOCOL};branch=${BRANCH}"
14SRCREV = "${IQN2_LLD_SRCREV}"
8 15
9PV = "1.0.0.8" 16PV = "1.0.0.8"
17INC_PR = "r1"
10 18
11COMPATIBLE_MACHINE = "k2l-evm" 19COMPATIBLE_MACHINE = "k2l-evm"
12 20
13S = "${WORKDIR}/git/ti/drv/iqn2" 21S = "${WORKDIR}/${IQN2_LLD_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb
index 19ffc053..4e681169 100644
--- a/recipes-bsp/iqn2-lld/iqn2-lld_git.bb
+++ b/recipes-bsp/iqn2-lld/iqn2-lld_git.bb
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip"
4 4
5include iqn2-lld.inc 5include iqn2-lld.inc
6 6
7PR = "${INC_PR}.0"
8
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}" 9EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
8 10
9do_compile () { 11do_compile () {