summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ipumm-fw
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2014-10-22 23:38:22 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-27 21:42:49 -0400
commit52774fad0402a1c13647e56ee769a95489deceef (patch)
tree1aeb5b04d6e17a42f31dfd382ca956db1ce1379e /recipes-bsp/ipumm-fw
parent129783a9cba7902feb7f35d390b37d96b733a201 (diff)
downloadmeta-ti-52774fad0402a1c13647e56ee769a95489deceef.tar.gz
ipumm-fw: Updated ipumm firmware for latest IPC version
* This includes the error handling support. * Minor bug fixes * Relax support for entire DRA7xx SOC family to cover AM57x Signed-off-by: Karthik Ramanan <a0393906@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/ipumm-fw')
-rw-r--r--recipes-bsp/ipumm-fw/ipumm-fw_3.00.06.00.bb (renamed from recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb)25
1 files changed, 12 insertions, 13 deletions
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.06.00.bb
index 7f67c39a..1cf24cc2 100644
--- a/recipes-bsp/ipumm-fw/ipumm-fw_3.00.04.02.bb
+++ b/recipes-bsp/ipumm-fw/ipumm-fw_3.00.06.00.bb
@@ -6,32 +6,29 @@ python __anonymous() {
6 raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES') 6 raise bb.parse.SkipPackage('ipumm-fw does not apply to systems without the "mmip" flag in MACHINE_FEATURES')
7} 7}
8 8
9DESCRIPTION = "Firmware for IPU " 9DESCRIPTION = "Firmware for IPU for supporting Accelerated MM decode and encode"
10
11LICENSE = "TI-TSPA" 10LICENSE = "TI-TSPA"
12LIC_FILES_CHKSUM_dra7xx = "file://MMIP-${PV}-Manifest.doc;md5=64ca6f9d7e5243b8a4084eb918a543bc" 11
12LIC_FILES_CHKSUM_dra7xx = "file://MMIP-${PV}-Manifest.doc;md5=8206ccaf28c2932afb5afd9c9575287c"
13LIC_FILES_CHKSUM_omap5-evm = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45" 13LIC_FILES_CHKSUM_omap5-evm = "file://MMIP-${PV}-Manifest.doc;md5=39a593dd8fc2a9654c74f679ed329c45"
14 14
15COMPATIBLE_MACHINE = "omap-a15" 15COMPATIBLE_MACHINE = "dra7xx|omap5-evm"
16PACKAGE_ARCH = "${MACHINE_ARCH}" 16PACKAGE_ARCH = "${MACHINE_ARCH}"
17 17
18# Need to set the PLATFORM variable since now multiple MACHINEs are sharing 18SRC_URI_dra7xx = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_06_00/exports/ipumm-dra7xx-evm-3.00.06.00.tar.gz;protocol=ftp;name=dra7xx-evm"
19# a common named tarball
20PLATFORM = "UNKNOWN"
21PLATFORM_dra7xx = "dra7xx-evm"
22PLATFORM_omap5-evm = "omap5-evm"
23 19
24SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${PLATFORM}-3.00.04.02.tar.gz;protocol=http;name=${PLATFORM}" 20SRC_URI_omap5-evm = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/ipumm/3_00_04_02/exports/ipumm-${MACHINE}-3.00.04.02.tar.gz;protocol=http;name=${MACHINE}"
25 21
26# DRA7xx checksums 22# DRA7xx checksums
27SRC_URI[dra7xx-evm.md5sum] = "da04c03b0fd57901e8283afa80f81379" 23SRC_URI[dra7xx-evm.md5sum] = "8e1ae40eb10d631318d001463fa11d79"
28SRC_URI[dra7xx-evm.sha256sum] = "0b26fd13f9c318b52c18b9bff56862ef1f58a768b19285b87c035e65bc828ddc" 24SRC_URI[dra7xx-evm.sha256sum] = "30c275146c34d11dbc2dfd568f0bbc3098a13cd981eee8a7a9766cb07d2f1ca5"
29 25
30# OMAP5 checksums 26# OMAP5 checksums
31SRC_URI[omap5-evm.md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a" 27SRC_URI[omap5-evm.md5sum] = "1572073ebd4f6d127c4e8cf47d270b6a"
32SRC_URI[omap5-evm.sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65" 28SRC_URI[omap5-evm.sha256sum] = "2fdb469f19e3c9984854f5bc82444fca4d7da869f5e645da22ec0d5beaa5cc65"
33 29
34S = "${WORKDIR}/ipumm-${MACHINE}-${PV}" 30S_dra7xx = "${WORKDIR}/ipumm-dra7xx-evm-${PV}"
31S_omap5-evm = "${WORKDIR}/ipumm-${MACHINE}-${PV}"
35 32
36TARGET_dra7xx = "dra7-ipu2-fw.xem4" 33TARGET_dra7xx = "dra7-ipu2-fw.xem4"
37TARGET_omap5-evm = "ducati-m3-core0.xem3" 34TARGET_omap5-evm = "ducati-m3-core0.xem3"
@@ -42,3 +39,5 @@ do_install() {
42} 39}
43 40
44FILES_${PN} += "${base_libdir}/firmware/${TARGET}" 41FILES_${PN} += "${base_libdir}/firmware/${TARGET}"
42
43PR = "r1"