diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2017-11-03 01:19:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-11-28 21:24:02 -0500 |
commit | 15e34b73e580e92dc98b120e28d2eeeec208260d (patch) | |
tree | 3f1657ea93d078628f1a4589120fecbc5415ed98 /recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb | |
parent | 97c308121c52326722994f0042326ffaee00d17f (diff) | |
download | meta-ti-15e34b73e580e92dc98b120e28d2eeeec208260d.tar.gz |
icss-emac-lld: update to version 1.0.0.8
* Extend compatibility to k2g-evm
* Simplify compile and install tasks as "TARGET" is no longer needed.
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb')
-rw-r--r-- | recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb | 47 |
1 files changed, 15 insertions, 32 deletions
diff --git a/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb b/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb index f62bf332..5093d7ce 100644 --- a/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb +++ b/recipes-bsp/icss-emac-lld/icss-emac-lld-test_git.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | DESCRIPTION = "TI ICSS-EMAC low level driver tests" | 1 | DESCRIPTION = "TI ICSS-EMAC low level driver tests" |
2 | 2 | ||
3 | DEPENDS="common-csl-ip pruss-lld icss-emac-lld osal" | 3 | DEPENDS="common-csl-ip pruss-lld icss-emac-lld osal ti-pdk-build-rtos icss-emac-lld-rtos" |
4 | 4 | ||
5 | DEPENDS_append_ti33x = " starterware" | 5 | DEPENDS_append_ti33x = " starterware" |
6 | DEPENDS_append_ti43x = " starterware" | 6 | DEPENDS_append_ti43x = " starterware" |
@@ -9,39 +9,22 @@ include icss-emac-lld.inc | |||
9 | 9 | ||
10 | PR = "${INC_PR}.0" | 10 | PR = "${INC_PR}.0" |
11 | 11 | ||
12 | COMPATIBLE_MACHINE = "am57xx-evm|ti33x|ti43x" | 12 | EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PDK_PKG_PATH=${STAGING_DATADIR}/ti/ti-pdk-tree/packages ICSS_EMAC_SRC_DIR=${S}" |
13 | 13 | ||
14 | EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} ICSS_EMAC_SRC_DIR=${S}" | 14 | DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}" |
15 | 15 | ||
16 | do_compile_am57xx-evm () { | 16 | do_compile () { |
17 | # Build the tests | 17 | # Build the tests |
18 | oe_runmake tests DEVICE="am571x" TARGET="SOC_AM571x" | 18 | for device in ${DEVICE_LIST} |
19 | oe_runmake clean | 19 | do |
20 | oe_runmake tests DEVICE="am572x" TARGET="SOC_AM572x" | 20 | oe_runmake tests DEVICE="$device" |
21 | done | ||
21 | } | 22 | } |
22 | 23 | ||
23 | do_compile_ti33x () { | 24 | do_install() { |
24 | # Build the tests | 25 | # Install the binary |
25 | oe_runmake tests DEVICE="am335x" TARGET="SOC_AM335x" | 26 | for device in ${DEVICE_LIST} |
26 | } | 27 | do |
27 | 28 | oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | |
28 | do_compile_ti43x () { | 29 | done |
29 | # Build the tests | ||
30 | oe_runmake tests DEVICE="am437x" TARGET="SOC_AM437x" | ||
31 | } | ||
32 | |||
33 | do_install_am57xx-evm () { | ||
34 | # Install the binary | ||
35 | oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am571x" TARGET="SOC_AM571x" | ||
36 | oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am572x" TARGET="SOC_AM572x" | ||
37 | } | ||
38 | |||
39 | do_install_ti33x () { | ||
40 | # Install the binary | ||
41 | oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am335x" TARGET="SOC_AM335x" | ||
42 | } | ||
43 | |||
44 | do_install_ti43x () { | ||
45 | # Install the binary | ||
46 | oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="am437x" TARGET="SOC_AM437x" | ||
47 | } | 30 | } |