diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-07-19 05:03:20 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:03:41 -0400 |
commit | 3ddab056c735dbbaf00ed8024b66efe9fb364c60 (patch) | |
tree | 1e2777116881d9fd0bc6173876a4af6b55829941 /recipes-bsp/i2c-lld | |
parent | 7a8cbf103754be4d9a42bc747255ad54aa6f768e (diff) | |
download | meta-ti-3ddab056c735dbbaf00ed8024b66efe9fb364c60.tar.gz |
i2c-lld-rtos: Add rtos recipe for i2c-lld
Upstreaming TI RTOS low level driver for I2C module
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/i2c-lld')
-rw-r--r-- | recipes-bsp/i2c-lld/i2c-lld-rtos_git.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-bsp/i2c-lld/i2c-lld-rtos_git.bb b/recipes-bsp/i2c-lld/i2c-lld-rtos_git.bb new file mode 100644 index 00000000..4f711b8e --- /dev/null +++ b/recipes-bsp/i2c-lld/i2c-lld-rtos_git.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "TI RTOS low level driver for Inter-IC module (I2C)" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://I2C.h;beginline=1;endline=32;md5=147a6773e962b103cd162ca58535289c" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | I2C_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/i2c-lld.git" | ||
12 | I2C_LLD_GIT_PROTOCOL = "git" | ||
13 | I2C_LLD_GIT_BRANCH = "master" | ||
14 | I2C_LLD_GIT_DESTSUFFIX = "git/ti/drv/i2c" | ||
15 | |||
16 | # Below commit ID corresponds to "DEV.I2C_LLD.01.00.00.07A" | ||
17 | I2C_LLD_SRCREV = "85ad56fb6e1f2bdabdd3c371b97170cb62a6fdd7" | ||
18 | |||
19 | BRANCH = "${I2C_LLD_GIT_BRANCH}" | ||
20 | SRC_URI = "${I2C_LLD_GIT_URI};destsuffix=${I2C_LLD_GIT_DESTSUFFIX};protocol=${I2C_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
21 | |||
22 | SRCREV = "${I2C_LLD_SRCREV}" | ||
23 | PV = "01.00.00.07A" | ||
24 | PR = "r0" | ||
25 | |||
26 | DEPENDS_append = " osal-rtos \ | ||
27 | " | ||
28 | DEPENDS_append_ti33x = " starterware-rtos \ | ||
29 | " | ||
30 | DEPENDS_append_ti43x = " starterware-rtos \ | ||
31 | " | ||
32 | |||
33 | # Build with make instead of XDC | ||
34 | TI_PDK_XDCMAKE = "0" | ||
35 | |||
36 | S = "${WORKDIR}/${I2C_LLD_GIT_DESTSUFFIX}" | ||
37 | |||
38 | export PDK_I2C_ROOT_PATH ="${WORKDIR}/build" | ||
39 | export DEST_ROOT="${S}" | ||
40 | |||
41 | # HTML doc link params | ||
42 | PDK_COMP_LINK_TEXT = "I2C LLD" | ||