summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/hyplnk-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-04-11 03:52:27 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-04-10 18:08:41 -0400
commit3a17af114edc5c0e1178ce90789a8afabad056fb (patch)
tree9cf988276e59f4cee4bb82af3132cee7d9e716b0 /recipes-bsp/hyplnk-lld
parent79945047c74dc914073d0cd7f157a271259076e7 (diff)
downloadmeta-ti-3a17af114edc5c0e1178ce90789a8afabad056fb.tar.gz
hyplnk-lld: Update to new version 2.1.0.2
- Add init script to add symbolic link for generic device library - remove unused CHOICELIST Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/hyplnk-lld')
-rwxr-xr-xrecipes-bsp/hyplnk-lld/files/init_hyplnk.sh47
-rw-r--r--recipes-bsp/hyplnk-lld/hyplnk-lld.inc8
-rwxr-xr-xrecipes-bsp/hyplnk-lld/hyplnk-lld_git.bb18
3 files changed, 66 insertions, 7 deletions
diff --git a/recipes-bsp/hyplnk-lld/files/init_hyplnk.sh b/recipes-bsp/hyplnk-lld/files/init_hyplnk.sh
new file mode 100755
index 00000000..fb650575
--- /dev/null
+++ b/recipes-bsp/hyplnk-lld/files/init_hyplnk.sh
@@ -0,0 +1,47 @@
1#*
2#* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/
3#*
4#*
5#* Redistribution and use in source and binary forms, with or without
6#* modification, are permitted provided that the following conditions
7#* are met:
8#*
9#* Redistributions of source code must retain the above copyright
10#* notice, this list of conditions and the following disclaimer.
11#*
12#* Redistributions in binary form must reproduce the above copyright
13#* notice, this list of conditions and the following disclaimer in the
14#* documentation and/or other materials provided with the
15#* distribution.
16#*
17#* Neither the name of Texas Instruments Incorporated nor the names of
18#* its contributors may be used to endorse or promote products derived
19#* from this software without specific prior written permission.
20#*
21
22#! /bin/sh
23compatible=$(cat /proc/device-tree/compatible)
24
25cd /usr/lib
26case "$compatible" in
27 *k2hk*)
28 device=k2hk
29 ln -sf libhyplnk_k2h.so.1.0.0 libhyplnk_device.so.1
30 ;;
31 *k2l*)
32 device=k2l
33 ln -sf libhyplnk_k2l.so.1.0.0 libhyplnk_device.so.1
34 ;;
35 *k2e*)
36 device=k2e
37 ln -sf libhyplnk_k2e.so.1.0.0 libhyplnk_device.so.1
38 ;;
39 *)
40 device=unknown
41 ;;
42esac
43
44if [ $device != unknown ]; then
45 ln -sf libhyplnk_device.so.1 libhyplnk_device.so
46 echo hyplnk library link established for device : $device
47fi
diff --git a/recipes-bsp/hyplnk-lld/hyplnk-lld.inc b/recipes-bsp/hyplnk-lld/hyplnk-lld.inc
index 4c8bb32a..7f46b7dc 100644
--- a/recipes-bsp/hyplnk-lld/hyplnk-lld.inc
+++ b/recipes-bsp/hyplnk-lld/hyplnk-lld.inc
@@ -9,11 +9,11 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/${LLDNAME}/COPYING.txt;md5=6233
9 9
10BRANCH="master" 10BRANCH="master"
11SRC_URI = "git://git.ti.com/keystone-rtos/hyplnk-lld.git;destsuffix=git/ti/drv/${LLDNAME};protocol=git;branch=${BRANCH}" 11SRC_URI = "git://git.ti.com/keystone-rtos/hyplnk-lld.git;destsuffix=git/ti/drv/${LLDNAME};protocol=git;branch=${BRANCH}"
12# Following commit corresponds to tag DEV.HYPLNK_LLD.02.01.00.01 12# Following commit corresponds to tag DEV.HYPLNK_LLD.02.01.00.02
13SRCREV = "6910da379501984ecf27f8d23ba6fc6310fe387e" 13SRCREV = "8451586025a0cf561ed9bc6ab70a2cad88a7e95e"
14 14
15PV = "2.1.0" 15PV = "2.1.0.2"
16PR = "r0" 16PR = "r1"
17 17
18DEVICELIST = " k2h \ 18DEVICELIST = " k2h \
19 k2k \ 19 k2k \
diff --git a/recipes-bsp/hyplnk-lld/hyplnk-lld_git.bb b/recipes-bsp/hyplnk-lld/hyplnk-lld_git.bb
index a582f981..8be072ca 100755
--- a/recipes-bsp/hyplnk-lld/hyplnk-lld_git.bb
+++ b/recipes-bsp/hyplnk-lld/hyplnk-lld_git.bb
@@ -2,9 +2,13 @@ include hyplnk-lld.inc
2 2
3DEPENDS = "common-csl-ip" 3DEPENDS = "common-csl-ip"
4 4
5CHOICELIST = " yes \ 5SRC_URI += "file://init_hyplnk.sh"
6 no \ 6
7" 7inherit update-rc.d
8
9INITSCRIPT_NAME = "init_hyplnk.sh"
10INITSCRIPT_PARAMS = "defaults 10"
11
8do_compile () { 12do_compile () {
9 make -f makefile_armv7 clean PDK_INSTALL_PATH="${STAGING_INCDIR}" \ 13 make -f makefile_armv7 clean PDK_INSTALL_PATH="${STAGING_INCDIR}" \
10 HYPLNK_SRC_DIR="${S}" 14 HYPLNK_SRC_DIR="${S}"
@@ -19,4 +23,12 @@ do_install () {
19 make -f makefile_armv7 install PDK_INSTALL_PATH="${STAGING_INCDIR}" \ 23 make -f makefile_armv7 install PDK_INSTALL_PATH="${STAGING_INCDIR}" \
20 INSTALL_INC_BASE_DIR="${D}/${includedir}" \ 24 INSTALL_INC_BASE_DIR="${D}/${includedir}" \
21 INSTALL_LIB_BASE_DIR="${D}${libdir}" HYPLNK_SRC_DIR="${S}" 25 INSTALL_LIB_BASE_DIR="${D}${libdir}" HYPLNK_SRC_DIR="${S}"
26# Set the generic device library symbolic link to default k2h
27 cd ${D}${libdir}
28 ln -sf libhyplnk_k2h.so.1.0.0 libhyplnk_device.so.1
29 ln -sf libhyplnk_device.so.1 libhyplnk_device.so
30# Copy init scripts
31 install -d ${D}${sysconfdir}/init.d/
32 install -c -m 755 ${WORKDIR}/init_hyplnk.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
33
22} 34}