summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/hplib/hplib_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-01-10 09:07:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-21 15:15:07 -0500
commitca6a156ea89a1632cf3d97dafece66ea26784894 (patch)
treeb4de0a8693a4e1da099c76d5b1a71e9fbb2b7128 /recipes-bsp/hplib/hplib_git.bb
parent6a7aa3b035b401717343f10abe7abdc3312529d8 (diff)
downloadmeta-ti-ca6a156ea89a1632cf3d97dafece66ea26784894.tar.gz
hplib: Add recipe for TI high performance library
- Provides high performance library, kernel module, user space libraries and test binaries - Supports devices k2h, k2k, k2l & k2e Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/hplib/hplib_git.bb')
-rw-r--r--recipes-bsp/hplib/hplib_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/hplib/hplib_git.bb b/recipes-bsp/hplib/hplib_git.bb
new file mode 100644
index 00000000..fbb3004c
--- /dev/null
+++ b/recipes-bsp/hplib/hplib_git.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "TI High performance libraries"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/runtime/hplib/src/COPYING.txt;md5=b7982a377c680ad71ca2fbb735982462"
4
5DEPENDS = "common-csl-ip rm-lld qmss-lld sa-lld pktlib"
6
7include hplib.inc
8
9CHOICELIST = "yes no"
10
11S = "${WORKDIR}/git/ti/runtime/hplib"
12
13EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
14
15do_compile () {
16 for device in ${DEVICELIST}
17 do
18 for choice in ${CHOICELIST}
19 do
20 oe_runmake lib HPLIB_SRC_DIR=${S} USEDYNAMIC_LIB=$choice DEVICE="$device"
21 done
22 done
23}
24
25do_install () {
26 for device in ${DEVICELIST}
27 do
28 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
29 done
30}