diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-07-19 05:03:19 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:03:37 -0400 |
commit | 7a8cbf103754be4d9a42bc747255ad54aa6f768e (patch) | |
tree | a63d707207ac004b8df12cec4410769bc7b035e8 /recipes-bsp/gpmc-lld | |
parent | 73540c8f5ef96ed34e08bc9dd7c0414c25787434 (diff) | |
download | meta-ti-7a8cbf103754be4d9a42bc747255ad54aa6f768e.tar.gz |
gpmc-lld-rtos: Added rtos recipe for gpmc-lld
Upstreaming RTOS low level driver for General purpose memory controller
(GPMC)
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/gpmc-lld')
-rw-r--r-- | recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb b/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb new file mode 100644 index 00000000..01ea5010 --- /dev/null +++ b/recipes-bsp/gpmc-lld/gpmc-lld-rtos_git.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "TI RTOS low level driver for General Purpose Memory Controller (GPMC)" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://GPMC.h;beginline=1;endline=31;md5=485ec97c36f809bf92323fde3e988c72" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | GPMC_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/gpmc-lld.git" | ||
12 | GPMC_LLD_GIT_PROTOCOL = "git" | ||
13 | GPMC_LLD_GIT_BRANCH = "master" | ||
14 | |||
15 | # Below commit ID corresponds to "DEV.GPMC_LLD.01.00.00.01" | ||
16 | GPMC_LLD_SRCREV = "86df4c099ad9c84f4b92d515ba64c343c75cf44d" | ||
17 | |||
18 | BRANCH = "${GPMC_LLD_GIT_BRANCH}" | ||
19 | SRC_URI = "${GPMC_LLD_GIT_URI};protocol=${GPMC_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
20 | |||
21 | SRCREV = "${GPMC_LLD_SRCREV}" | ||
22 | PV = "01.00.00.01" | ||
23 | PR = "r0" | ||
24 | |||
25 | DEPENDS_append = " osal-rtos \ | ||
26 | " | ||
27 | DEPENDS_append_ti33x = " starterware-rtos \ | ||
28 | " | ||
29 | DEPENDS_append_ti43x = " starterware-rtos \ | ||
30 | " | ||
31 | |||
32 | # Build with make instead of XDC | ||
33 | TI_PDK_XDCMAKE = "0" | ||
34 | |||
35 | # HTML doc link params | ||
36 | PDK_COMP_LINK_TEXT = "GPMC LLD" | ||
37 | |||
38 | export PDK_GPMC_ROOT_PATH ="${WORKDIR}/build" | ||
39 | export DEST_ROOT="${S}" | ||