summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/gc320-drivers
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-10-18 07:04:18 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-10-18 22:51:37 +0000
commitfab8b9c0331533cfdf02a390bd1d2bcfce557c95 (patch)
tree3d82468a2c36a27eb70f4334bb48b416a23b0c60 /recipes-bsp/gc320-drivers
parent54ba95b3756d901d6093d03645b8ab8dcf9a38f9 (diff)
downloadmeta-ti-fab8b9c0331533cfdf02a390bd1d2bcfce557c95.tar.gz
ti-gc320-driver: workaround for gcc8 stringop-overflow error
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/gc320-drivers')
-rw-r--r--recipes-bsp/gc320-drivers/ti-gc320-driver/0001-Kbuild-bypass-gcc8-stringop-overflow-error.patch26
-rw-r--r--recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb4
2 files changed, 29 insertions, 1 deletions
diff --git a/recipes-bsp/gc320-drivers/ti-gc320-driver/0001-Kbuild-bypass-gcc8-stringop-overflow-error.patch b/recipes-bsp/gc320-drivers/ti-gc320-driver/0001-Kbuild-bypass-gcc8-stringop-overflow-error.patch
new file mode 100644
index 00000000..431afa76
--- /dev/null
+++ b/recipes-bsp/gc320-drivers/ti-gc320-driver/0001-Kbuild-bypass-gcc8-stringop-overflow-error.patch
@@ -0,0 +1,26 @@
1From c93a4217425ffebae1fb2d5c6c7fc957eb8aa18c Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Tue, 16 Oct 2018 21:16:48 -0400
4Subject: [PATCH] Kbuild: bypass gcc8 stringop-overflow error
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7---
8 src/Kbuild | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/Kbuild b/src/Kbuild
12index 574a107..df4368d 100755
13--- a/src/Kbuild
14+++ b/src/Kbuild
15@@ -87,7 +87,7 @@ MODULE_NAME ?= galcore
16 CUSTOMER_ALLOCATOR_OBJS ?=
17 ALLOCATOR_ARRAY_H_LOCATION ?= $(OS_KERNEL_DIR)/allocator/default/
18
19-EXTRA_CFLAGS += -Werror
20+EXTRA_CFLAGS += -Werror -Wno-stringop-overflow
21
22 OBJS := $(OS_KERNEL_DIR)/gc_hal_kernel_device.o \
23 $(OS_KERNEL_DIR)/gc_hal_kernel_linux.o \
24--
252.7.4
26
diff --git a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
index d29b6496..1a6bc5da 100644
--- a/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
+++ b/recipes-bsp/gc320-drivers/ti-gc320-driver_5.0.11.p7.bb
@@ -13,7 +13,9 @@ BRANCH = "ti-${PV}-k4.14"
13 13
14SRCREV = "a36799d9329efcfff19e30e690156d5ebf7e0c55" 14SRCREV = "a36799d9329efcfff19e30e690156d5ebf7e0c55"
15 15
16SRC_URI = "git://git.ti.com/graphics/ti-gc320-driver.git;protocol=git;branch=${BRANCH}" 16SRC_URI = "git://git.ti.com/graphics/ti-gc320-driver.git;protocol=git;branch=${BRANCH} \
17 file://0001-Kbuild-bypass-gcc8-stringop-overflow-error.patch;striplevel=2"
18
17S = "${WORKDIR}/git/src" 19S = "${WORKDIR}/git/src"
18 20
19EXTRA_OEMAKE += "-f Kbuild AQROOT=${S} KERNEL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_PATH=${TOOLCHAIN_PATH} CROSS_COMPILE=${TARGET_PREFIX} ARCH_TYPE=${TARGET_ARCH}" 21EXTRA_OEMAKE += "-f Kbuild AQROOT=${S} KERNEL_DIR=${STAGING_KERNEL_DIR} TOOLCHAIN_PATH=${TOOLCHAIN_PATH} CROSS_COMPILE=${TARGET_PREFIX} ARCH_TYPE=${TARGET_ARCH}"