diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-07-19 05:03:17 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-08-22 16:03:31 -0400 |
commit | 66cdd7b418b07345d050aa3c6b0a639c7aafc791 (patch) | |
tree | 4267878b903f0af595272c4f76deabd853005c0d /recipes-bsp/fatfs-rtos | |
parent | a338a4ffb3f144834e6212f2faeeb6538f1266bd (diff) | |
download | meta-ti-66cdd7b418b07345d050aa3c6b0a639c7aafc791.tar.gz |
fatfs-rtos: Added fatfs recipe for rtos
Upstreaming TI RTOS driver for FAT file system
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/fatfs-rtos')
-rw-r--r-- | recipes-bsp/fatfs-rtos/fatfs-rtos_git.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/fatfs-rtos/fatfs-rtos_git.bb b/recipes-bsp/fatfs-rtos/fatfs-rtos_git.bb new file mode 100644 index 00000000..0b8a6dfa --- /dev/null +++ b/recipes-bsp/fatfs-rtos/fatfs-rtos_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "TI RTOS driver for FAT filesystem" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://FATFS.h;beginline=1;endline=32;md5=6619832755598d1cc2b01f2e6a1801d6" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g|omapl1" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | FATFS_GIT_URI = "git://git.ti.com/keystone-rtos/fatfs.git" | ||
12 | FATFS_GIT_PROTOCOL = "git" | ||
13 | FATFS_GIT_BRANCH = "master" | ||
14 | |||
15 | # Below commit ID corresponds to "DEV.FATFS_LLD.01.00.00.06A" | ||
16 | FATFS_SRCREV = "7cb9e45da11cd3c60fe48c38c9dcdaa6e49a8276" | ||
17 | |||
18 | BRANCH ="${FATFS_GIT_BRANCH}" | ||
19 | SRC_URI = "${FATFS_GIT_URI};protocol=${FATFS_GIT_PROTOCOL};branch=${BRANCH}" | ||
20 | |||
21 | SRCREV = "${FATFS_SRCREV}" | ||
22 | PV = "01.00.00.06A" | ||
23 | PR = "r0" | ||
24 | |||
25 | DEPENDS_append = " mmcsd-lld-rtos \ | ||
26 | " | ||
27 | # Build with make instead of XDC | ||
28 | TI_PDK_XDCMAKE = "0" | ||
29 | |||
30 | export PDK_FATFS_ROOT_PATH ="${WORKDIR}/build" | ||
31 | export DEST_ROOT="${S}" | ||
32 | |||
33 | # HTML doc link params | ||
34 | PDK_COMP_LINK_TEXT = "FATFS Library" | ||