summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/emac-lld
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-10-26 23:19:54 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-10-30 15:16:06 -0400
commita74e634032ac1d217487fbed491474a146b848d9 (patch)
tree9dbc1d91572eb8d2e02b6a9281c5a277c50aaff9 /recipes-bsp/emac-lld
parenta2f7a2aff7934b28de7a40a30dcc952bd3e579d6 (diff)
downloadmeta-ti-a74e634032ac1d217487fbed491474a146b848d9.tar.gz
emac-lld-rtos: Added emac-lld-rtos recipe
RTOS low level driver for Ethernet MAC Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/emac-lld')
-rw-r--r--recipes-bsp/emac-lld/emac-lld-rtos_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/emac-lld/emac-lld-rtos_git.bb b/recipes-bsp/emac-lld/emac-lld-rtos_git.bb
new file mode 100644
index 00000000..551ffed2
--- /dev/null
+++ b/recipes-bsp/emac-lld/emac-lld-rtos_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "TI RTOS low level driver for Ethernet MAC (EMAC) peripheral"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://emacver.h;beginline=1;endline=47;md5=f66bb3695972ca2a85d990a390f45d88"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g|omapl1|c665x-evm"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11EMAC_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/emac-lld.git"
12EMAC_LLD_GIT_PROTOCOL = "git"
13EMAC_LLD_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.EMAC_LLD.01.00.03.07"
16EMAC_LLD_SRCREV = "70bb4d2ed677d428f055c2178e95766511e14383"
17
18BRANCH ="${EMAC_LLD_GIT_BRANCH}"
19SRC_URI = "${EMAC_LLD_GIT_URI};protocol=${EMAC_LLD_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${EMAC_LLD_SRCREV}"
22PV = "01.00.03.07"
23PR = "r0"
24
25DEPENDS_append = " board-rtos osal-rtos"
26DEPENDS_append_ti33x = " starterware-rtos"
27DEPENDS_append_ti43x = " starterware-rtos"
28DEPENDS_append_k2g = " cppi-lld-rtos qmss-lld-rtos"
29
30# HTML doc link params
31PDK_COMP_LINK_TEXT = "EMAC LLD"