summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/edma3-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-11-19 19:21:33 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-15 15:00:57 -0500
commit123dac8c82f03f117b3fdf361c9592304071983f (patch)
tree6d7b5fa35a8b0c918801c3e0db42189e769cb6b9 /recipes-bsp/edma3-lld
parentf81589410d96d123b6143d1bc8e33374775e7d7c (diff)
downloadmeta-ti-123dac8c82f03f117b3fdf361c9592304071983f.tar.gz
edma3-lld: add new recipe for edma3 low level driver
- Provides low level driver for EDMA3 module - supports k2k, k2l, k2e evm platforms Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/edma3-lld')
-rwxr-xr-xrecipes-bsp/edma3-lld/edma3-lld_git.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/recipes-bsp/edma3-lld/edma3-lld_git.bb b/recipes-bsp/edma3-lld/edma3-lld_git.bb
new file mode 100755
index 00000000..1ed4b93c
--- /dev/null
+++ b/recipes-bsp/edma3-lld/edma3-lld_git.bb
@@ -0,0 +1,80 @@
1DESCRIPTION = "TI EDMA3 low level driver and test code"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=5bdceac872dffdec915b819654ee23ea"
4
5BRANCH = "master"
6SRC_URI = "git://git.ti.com/keystone-rtos/edma3_lld.git"
7# The following commit corresponds to tag DEV_EDMA3_LLD_02_11_13_17
8SRCREV = "8c27e548fa53ca8472404ef347b8f6b6e2588d46"
9
10PV = "2.11.13"
11PR = "r0"
12
13COMPATIBLE_MACHINE = "keystone"
14
15DEPENDS = "common-csl-ip"
16
17PLATFORMLIST = "tci6636k2h-evm \
18 tci6638k2k-evm \
19 tci6630k2l-evm \
20 c66ak2e-evm \
21 "
22
23PACKAGES =+ "${PN}-test"
24
25FILES_${PN}-test = "${bindir}/*"
26
27S = "${WORKDIR}/git"
28
29do_compile () {
30 cd ${S}/packages
31 for platform in ${PLATFORMLIST}
32 do
33 ROOTDIR=${S} CROSSCC="${TARGET_PREFIX}gcc" CROSSAR="${TARGET_PREFIX}ar" \
34 CROSSLNK="${TARGET_PREFIX}gcc" INTERNAL_SW_ROOT="${S}" make \
35 PLATFORM="$platform" TARGET=a15 TOOLCHAIN_a15=GCC FORMAT=ELF \
36 SONAME=libedma3.so all
37 done
38}
39
40do_install () {
41 install -d ${D}/${libdir}
42
43 # Static Libraries
44 cp ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/edma3_lld_drv.aa15fg \
45 ${D}/${libdir}/libedma3.a
46 cp ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/edma3_lld_rm.aa15fg \
47 ${D}/${libdir}/libedma3rm.a
48
49 # Shared Libraries
50 cp -a ${S}/packages/ti/sdo/edma3/drv/lib/a15/release/libedma* ${D}/${libdir}
51 cp -a ${S}/packages/ti/sdo/edma3/rm/lib/tci6636k2h-evm/a15/release/libedma* ${D}/${libdir}
52
53 # Copy Headers
54 install -d ${D}/${includedir}/ti/sdo/edma3/drv/
55 install -d ${D}/${includedir}/ti/sdo/edma3/rm
56 cp ${S}/packages/ti/sdo/edma3/drv/*.h ${D}/${includedir}/ti/sdo/edma3/drv/
57 cp ${S}/packages/ti/sdo/edma3/rm/*.h ${D}/${includedir}/ti/sdo/edma3/rm/
58
59 # Copy Sample Config
60 install -d ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms
61 cp ${S}/examples/edma3_user_space_driver/evmTCI6636K2H/evmTCI6636K2HSample.c \
62 ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms
63 cp ${S}/examples/edma3_user_space_driver/evmTCI6638K2K/evmTCI6638K2KSample.c \
64 ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms
65 cp ${S}/examples/edma3_user_space_driver/evmTCI6630K2L/evmTCI6630K2LSample.c \
66 ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms
67 cp ${S}/examples/edma3_user_space_driver/evmC66AK2E/evmC66AK2ESample.c \
68 ${D}/${includedir}/ti/sdo/edma3/drv/sample/src/platforms
69
70 install -d ${D}/${bindir}
71 install -c -m 755 ${S}/examples/edma3_user_space_driver/evmTCI6636K2H/bin/tci6636k2h-evm/edma3_drv_6636k2h_a15_sample_a15host_release.xa15fg \
72 ${D}/${bindir}/edma3_drv_6636k2h_a15_sample_a15host_release.xa15fg
73 install -c -m 755 ${S}/examples/edma3_user_space_driver/evmTCI6638K2K/bin/tci6638k2k-evm/edma3_drv_6638k2k_a15_sample_a15host_release.xa15fg \
74 ${D}/${bindir}/edma3_drv_6638k2k_a15_sample_a15host_release.xa15fg
75 install -c -m 755 ${S}/examples/edma3_user_space_driver/evmTCI6630K2L/bin/tci6630k2l-evm/edma3_drv_6630k2l_a15_sample_a15host_release.xa15fg \
76 ${D}/${bindir}/edma3_drv_6630k2l_a15_sample_a15host_release.xa15fg
77 install -c -m 755 ${S}/examples/edma3_user_space_driver/evmC66AK2E/bin/c66ak2e-evm/edma3_drv_c66ak2e_a15_sample_a15host_release.xa15fg \
78 ${D}/${bindir}/edma3_drv_c66ak2e_a15_sample_a15host_release.xa15fg
79}
80