summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dsptop
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-05-20 19:32:16 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-05-22 12:33:07 -0400
commit5f79e6fcaff436ef484ceb22571d84088b35478f (patch)
tree01025cce2fabd0de3d0c1ca27605b1ad38f94b58 /recipes-bsp/dsptop
parentd20340cdf0b99a9cb70c09eeae34cf7879706d8e (diff)
downloadmeta-ti-5f79e6fcaff436ef484ceb22571d84088b35478f.tar.gz
dsptop: Add version 1.2.0
* dsptop is a utility that provides a top-like interface to observe DSP resource usage in real-time. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/dsptop')
-rw-r--r--recipes-bsp/dsptop/dsptop_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/dsptop/dsptop_git.bb b/recipes-bsp/dsptop/dsptop_git.bb
new file mode 100644
index 00000000..4b6c729b
--- /dev/null
+++ b/recipes-bsp/dsptop/dsptop_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "TI dsptop utility."
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://debian/copyright;md5=309825aa8f5edfcf2c44912ac094b979"
4
5DEPENDS = "libulm ncurses"
6
7PR = "${INC_PR}.0"
8
9S = "${WORKDIR}/git/dsptop"
10
11DEVICE = ""
12DEVICE_dra7xx = "DRA7xx"
13DEVICE_keystone = "C66AK2Hxx"
14
15EXTRA_OEMAKE = "release DEVICE=${DEVICE} CROSS_COMPILE=${TARGET_PREFIX}"
16
17do_install() {
18 oe_runmake install DESTDIR=${D}
19}
20
21COMPATIBLE_MACHINE = "dra7xx|keystone"
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23
24RDEPENDS_${PN} = "debugss-module-drv"
25
26include dsptop.inc
27
28PARALLEL_MAKE = ""