summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dspdce-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2015-12-05 08:22:53 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-12-04 22:11:49 -0500
commit8a1736037d7e85e473073ded667e065d46912419 (patch)
tree0598c3155a80f3d557ecfc1c9c232bbcbeb142fd /recipes-bsp/dspdce-fw
parent3e02323dd2b49aaeac3bcb526ed971ba27c09158 (diff)
downloadmeta-ti-8a1736037d7e85e473073ded667e065d46912419.tar.gz
dspdce-fw: fix alternatives handling
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/dspdce-fw')
-rw-r--r--recipes-bsp/dspdce-fw/dspdce-fw_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
index cf4c34c0..6c6bb2af 100644
--- a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
+++ b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/git"
15require recipes-ti/includes/ti-paths.inc 15require recipes-ti/includes/ti-paths.inc
16require recipes-ti/includes/ti-staging.inc 16require recipes-ti/includes/ti-staging.inc
17 17
18PR = "r1" 18PR = "r2"
19inherit update-alternatives 19inherit update-alternatives
20 20
21DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native" 21DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native"
@@ -49,11 +49,12 @@ TARGET = "dra7-dsp1-fw.xe66"
49 49
50do_install() { 50do_install() {
51 mkdir -p ${D}${base_libdir}/firmware 51 mkdir -p ${D}${base_libdir}/firmware
52 cp ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET} 52 cp ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET}.${BPN}
53} 53}
54 54
55ALTERNATIVE_${PN} = "dra7-dsp1-fw.xe66" 55ALTERNATIVE_${PN} = "dra7-dsp1-fw.xe66"
56ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "/lib/firmware/${TARGET}" 56ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}"
57ALTERNATIVE_TARGET[dra7-dsp1-fw.xe66] = "${base_libdir}/firmware/${TARGET}.${BPN}"
57ALTERNATIVE_PRIORITY = "10" 58ALTERNATIVE_PRIORITY = "10"
58 59
59INSANE_SKIP_${PN} = "arch" 60INSANE_SKIP_${PN} = "arch"