diff options
author | Gou, Hongmei <h-gou@ti.com> | 2015-10-20 03:02:25 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-22 12:57:26 -0400 |
commit | 5f12d9f826344a8a27d9d77a4d1cb614ad4b8f2c (patch) | |
tree | 5bcc67dd270421b48ebb262f71606010f15d42c0 /recipes-bsp/dspdce-fw/dspdce-fw_git.bb | |
parent | 78a9eb7bec7e72eda822dbcace262f9c44c8e412 (diff) | |
download | meta-ti-5f12d9f826344a8a27d9d77a4d1cb614ad4b8f2c.tar.gz |
dspdce-fw: update recipe to build dspdce-fw from git source
Signed-off-by: Hongmei Gou <h-gou@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/dspdce-fw/dspdce-fw_git.bb')
-rw-r--r-- | recipes-bsp/dspdce-fw/dspdce-fw_git.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-bsp/dspdce-fw/dspdce-fw_git.bb b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb new file mode 100644 index 00000000..3beb4fbe --- /dev/null +++ b/recipes-bsp/dspdce-fw/dspdce-fw_git.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | DESCRIPTION = "Firmware for DSP for an example application called copycodectest" | ||
2 | LICENSE = "TI-TSPA" | ||
3 | LIC_FILES_CHKSUM = "file://src/ti/framework/dce/dce.c;startline=1;endline=31;md5=2c6e9aba6ed75f22b1a2b7544b1c809d" | ||
4 | |||
5 | COMPATIBLE_MACHINE = "dra7xx" | ||
6 | |||
7 | SRC_URI = "git://git.ti.com/glsdk/dspdce.git;protocol=git" | ||
8 | |||
9 | SRCREV = "71e8fbf8e4f91b60680cf18a0c202a222e9ae3ba" | ||
10 | |||
11 | PV = "1.00.00.06" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | require recipes-ti/includes/ti-paths.inc | ||
16 | require recipes-ti/includes/ti-staging.inc | ||
17 | |||
18 | PR = "r0" | ||
19 | inherit update-alternatives | ||
20 | |||
21 | DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ipc-rtos ti-osal ti-cgt6x-native" | ||
22 | |||
23 | export HWVERSION = "ES10" | ||
24 | export BIOSTOOLSROOT = "${STAGING_DIR_TARGET}/usr/share/ti" | ||
25 | |||
26 | export XDCVERSION = "ti-xdctools-tree" | ||
27 | export BIOSVERSION = "ti-sysbios-tree" | ||
28 | export IPCVERSION = "ti-ipc-tree" | ||
29 | export CEVERSION = "ti-codec-engine-tree" | ||
30 | export FCVERSION = "ti-framework-components-tree" | ||
31 | export XDAISVERSION = "ti-xdais-tree" | ||
32 | export OSALVERSION = "ti-osal-tree" | ||
33 | |||
34 | export IPCSRC = "${STAGING_DIR_TARGET}/usr/share/ti/ti-ipc-tree" | ||
35 | export C66XCGTOOLSPATH = "${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" | ||
36 | |||
37 | do_configure() { | ||
38 | cd ${S} | ||
39 | make unconfig | ||
40 | make vayu_config | ||
41 | } | ||
42 | |||
43 | do_compile() { | ||
44 | cd ${S} | ||
45 | make dspbin | ||
46 | } | ||
47 | |||
48 | TARGET = "dra7-dsp1-fw.xe66" | ||
49 | |||
50 | do_install() { | ||
51 | mkdir -p ${D}${base_libdir}/firmware | ||
52 | cp ${S}/dra7xx-c66x-dsp.xe66 ${D}${base_libdir}/firmware/${TARGET} | ||
53 | } | ||
54 | |||
55 | ALTERNATIVE_${PN} = "dra7-dsp1-fw.xe66" | ||
56 | ALTERNATIVE_LINK_NAME[dra7-dsp1-fw.xe66] = "/lib/firmware/${TARGET}" | ||
57 | ALTERNATIVE_PRIORITY = "10" | ||
58 | |||
59 | INSANE_SKIP_${PN} = "arch" | ||
60 | |||
61 | FILES_${PN} += "${base_libdir}/firmware/*" | ||