summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dfe-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-11 03:28:07 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-19 16:45:28 -0500
commitea65cbe1c9d448777658a877b41a928b9369e56c (patch)
treea69dbe25f975b7475eedd2d37063501f9baff2b6 /recipes-bsp/dfe-lld
parent56ea9223d7a3d3da38dd4fef10b4dfeb0667992d (diff)
downloadmeta-ti-ea65cbe1c9d448777658a877b41a928b9369e56c.tar.gz
dfe-lld: Add recipe for Digital Radio Front end low level driver
- Provides low level driver for Digital Radio front end - Supports device k2l Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/dfe-lld')
-rw-r--r--recipes-bsp/dfe-lld/dfe-lld.inc13
-rw-r--r--recipes-bsp/dfe-lld/dfe-lld_git.bb15
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/dfe-lld/dfe-lld.inc b/recipes-bsp/dfe-lld/dfe-lld.inc
new file mode 100644
index 00000000..4979499d
--- /dev/null
+++ b/recipes-bsp/dfe-lld/dfe-lld.inc
@@ -0,0 +1,13 @@
1LICENSE = "BSD-3-Clause"
2
3LIC_FILES_CHKSUM = "file://COPYING.txt;md5=1f4217b705bf98762a302fd720649dcc"
4BRANCH = "master"
5SRC_URI = "git://git.ti.com/keystone-rtos/dfe-lld.git;destsuffix=git/ti/drv/dfe;protocol=git;branch=${BRANCH}"
6# The following commit correspond to DEV.DFE_LLD.01.00.00.03C
7SRCREV = "ed20e87d3676e3e05ce2b78179b504a05083ad15"
8
9PV = "1.0.0.3"
10
11COMPATIBLE_MACHINE = "k2l-evm"
12
13S = "${WORKDIR}/git/ti/drv/dfe"
diff --git a/recipes-bsp/dfe-lld/dfe-lld_git.bb b/recipes-bsp/dfe-lld/dfe-lld_git.bb
new file mode 100644
index 00000000..a2477ca6
--- /dev/null
+++ b/recipes-bsp/dfe-lld/dfe-lld_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "Digital Radio Front End low level driver"
2
3DEPENDS = "common-csl-ip"
4
5include dfe-lld.inc
6
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
8
9do_compile () {
10 oe_runmake lib DEVICE=k2l
11}
12
13do_install () {
14 oe_runmake install INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
15}