summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/dfe-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-11 03:28:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-19 16:45:35 -0500
commit8d3547f81b83849609dde63bf735c8eca8b361e6 (patch)
tree97dcee3ef8719843d0fe6abc27c674632832e15b /recipes-bsp/dfe-lld
parentbfc42e6786167d6948bbceee7b82345738a960db (diff)
downloadmeta-ti-8d3547f81b83849609dde63bf735c8eca8b361e6.tar.gz
dfe-lld: Add recipe for dfe test code
- Adds test code for Digital front end low level driver Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/dfe-lld')
-rw-r--r--recipes-bsp/dfe-lld/dfe-lld-test_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-bsp/dfe-lld/dfe-lld-test_git.bb b/recipes-bsp/dfe-lld/dfe-lld-test_git.bb
new file mode 100644
index 00000000..acaaf637
--- /dev/null
+++ b/recipes-bsp/dfe-lld/dfe-lld-test_git.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "TI Digital Radio Front End lld test application"
2
3DEPENDS = "common-csl-ip dfe-lld iqn2-lld"
4
5include dfe-lld.inc
6
7EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} DFE_SRC_DIR=${S}"
8
9do_compile () {
10# Now build the lld in the updated directory
11 oe_runmake clean DEVICE=k2l
12 oe_runmake tests DEVICE=k2l
13 oe_runmake tests DEVICE=k2l USEDYNAMIC_LIB=yes
14}
15
16do_install () {
17 oe_runmake installbin INSTALL_BIN_BASE_DIR=${D}/${bindir}
18}