diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-01-16 00:48:31 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-01-15 21:35:15 -0500 |
commit | 6a7aa3b035b401717343f10abe7abdc3312529d8 (patch) | |
tree | 1604ff8fff43a87050144984fd4ec453444284ba /recipes-bsp/cuia/cuia_1.0.0.13.bb | |
parent | cf62459026d2f2042ea035f2cd618d823065e1ea (diff) | |
download | meta-ti-6a7aa3b035b401717343f10abe7abdc3312529d8.tar.gz |
cuia: Add recipe for TI unified Instrumentation Architecture in C module
- Provides instrumentation libraries in C for TI SoCs
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cuia/cuia_1.0.0.13.bb')
-rw-r--r-- | recipes-bsp/cuia/cuia_1.0.0.13.bb | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/cuia/cuia_1.0.0.13.bb b/recipes-bsp/cuia/cuia_1.0.0.13.bb new file mode 100644 index 00000000..42154d2f --- /dev/null +++ b/recipes-bsp/cuia/cuia_1.0.0.13.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "TI Unified Instrumentation Architecture in C (cUIA)" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://cuia_${CUIA_PV}_manifest.html;md5=0eea94e3bb94de4ddee77653eba1c7c5" | ||
4 | |||
5 | CUIA_PV = "1_00_00_13" | ||
6 | CUIA_PVExtra = "" | ||
7 | |||
8 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_ccstudio/UIA/SCMCSDK/cuia_${CUIA_PV}${CUIA_PVExtra}.tar.gz;name=cuia" | ||
9 | SRC_URI[cuia.md5sum] = "ef53989ac70c191841cd656cdc8770be" | ||
10 | SRC_URI[cuia.sha256sum] = "f16d138a9146fdc7d52cba77bd30596da65835f6ffe4092baf2b33d1c1a4fb0d" | ||
11 | |||
12 | S = "${WORKDIR}/cuia_${CUIA_PV}${CUIA_PVExtra}" | ||
13 | |||
14 | do_compile () { | ||
15 | cd ${S} | ||
16 | oe_runmake clean | ||
17 | oe_runmake all | ||
18 | } | ||
19 | |||
20 | do_install() { | ||
21 | cd ${S} | ||
22 | oe_runmake DESTDIR=${D} libdir=${libdir} includedir=${includedir} install | ||
23 | } | ||