diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:09 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:56:43 -0500 |
commit | 2801ef9ce5fc3846e61c99e16b39f553e65c632d (patch) | |
tree | d4ee00d7dd2837d1e34f2508d92ad6b3f73431a4 /recipes-bsp/cppi-lld | |
parent | 6042df4426cd1aebe3462f34ed82185983ed0449 (diff) | |
download | meta-ti-2801ef9ce5fc3846e61c99e16b39f553e65c632d.tar.gz |
cppi-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld.inc | 17 | ||||
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld_git.bb | 2 |
3 files changed, 16 insertions, 5 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb index 871546e3..8f4856a8 100644 --- a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" | |||
4 | 4 | ||
5 | include cppi-lld.inc | 5 | include cppi-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | CHOICELIST = "yes no" | 9 | CHOICELIST = "yes no" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc index 21c8fe00..ae81a3f0 100644 --- a/recipes-bsp/cppi-lld/cppi-lld.inc +++ b/recipes-bsp/cppi-lld/cppi-lld.inc | |||
@@ -1,14 +1,21 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | CPPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git;destsuffix=git/ti/drv/cppi;protocol=git;branch=${BRANCH}" | 5 | CPPI_LLD_GIT_PROTOCOL = "git" |
6 | CPPI_LLD_GIT_BRANCH = "master" | ||
7 | CPPI_LLD_GIT_DESTSUFFIX = "git/ti/drv/cppi" | ||
6 | 8 | ||
7 | # Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.10" | 9 | # Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.10" |
8 | SRCREV = "97c537fa544a78e83512db3499a49d0bd86fad32" | 10 | CPPI_LLD_SRCREV = "97c537fa544a78e83512db3499a49d0bd86fad32" |
11 | |||
12 | BRANCH = "${CPPI_LLD_GIT_BRANCH}" | ||
13 | SRC_URI = "${CPPI_LLD_GIT_URI};destsuffix=${CPPI_LLD_GIT_DESTSUFFIX};protocol=${CPPI_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | |||
15 | SRCREV = "${CPPI_LLD_SRCREV}" | ||
9 | PV = "02.01.00.10" | 16 | PV = "02.01.00.10" |
17 | INC_PR = "r1" | ||
10 | 18 | ||
11 | DEVICELIST = "k2h k2k k2l k2e" | 19 | DEVICELIST = "k2h k2k k2l k2e" |
12 | 20 | ||
13 | BASEDIR = "${WORKDIR}/git" | 21 | S = "${WORKDIR}/${CPPI_LLD_GIT_DESTSUFFIX}" |
14 | S = "${BASEDIR}/ti/drv/cppi" | ||
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb index cd419f6a..169e0fcb 100644 --- a/recipes-bsp/cppi-lld/cppi-lld_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -5,6 +5,8 @@ DEPENDS = "common-csl-ip rm-lld qmss-lld" | |||
5 | 5 | ||
6 | include cppi-lld.inc | 6 | include cppi-lld.inc |
7 | 7 | ||
8 | PR = "${INC_PR}.0" | ||
9 | |||
8 | SRC_URI += "file://init_cppi.sh" | 10 | SRC_URI += "file://init_cppi.sh" |
9 | 11 | ||
10 | inherit update-rc.d | 12 | inherit update-rc.d |