diff options
author | Sam Nelson <sam.nelson@ti.com> | 2014-12-17 00:12:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-12-18 12:43:27 -0500 |
commit | 70664faa8da48c0c8cfed96c89c038017b8bfea1 (patch) | |
tree | 3a4a876e29d72ed17b58b7e9db6e5d8d300ddbc0 /recipes-bsp/cppi-lld | |
parent | 123dac8c82f03f117b3fdf361c9592304071983f (diff) | |
download | meta-ti-70664faa8da48c0c8cfed96c89c038017b8bfea1.tar.gz |
cppi-lld: Add new recipe for CPPI Module low level driver
- Provides low level driver and test code for Communications port programming
interface module
- Supports k2h, k2k, k2l k2e devices
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rwxr-xr-x | recipes-bsp/cppi-lld/cppi-lld-test_git.bb | 26 | ||||
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld.inc | 15 | ||||
-rwxr-xr-x | recipes-bsp/cppi-lld/cppi-lld_git.bb | 19 |
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb new file mode 100755 index 00000000..871546e3 --- /dev/null +++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | DESCRIPTION = "TI CPPI low level driver unit test and example binaries" | ||
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" | ||
4 | |||
5 | include cppi-lld.inc | ||
6 | |||
7 | CHOICELIST = "yes no" | ||
8 | |||
9 | do_compile () { | ||
10 | # Now build the lld in the updated directory | ||
11 | for device in ${DEVICELIST} | ||
12 | do | ||
13 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} | ||
14 | for choice in ${CHOICELIST} | ||
15 | do | ||
16 | make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" | ||
17 | done | ||
18 | done | ||
19 | } | ||
20 | |||
21 | do_install () { | ||
22 | for device in ${DEVICELIST} | ||
23 | do | ||
24 | make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir} | ||
25 | done | ||
26 | } | ||
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc new file mode 100644 index 00000000..d26adc59 --- /dev/null +++ b/recipes-bsp/cppi-lld/cppi-lld.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | ||
3 | |||
4 | BRANCH = "master" | ||
5 | SRC_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git;destsuffix=git/ti/drv/cppi;protocol=git;branch=${BRANCH}" | ||
6 | |||
7 | # Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.06" | ||
8 | SRCREV = "4c6c0a857786c49d8003453d3bc7c3c97ff4f5a4" | ||
9 | PV = "02.01.00.06" | ||
10 | PR = "r0" | ||
11 | |||
12 | DEVICELIST = "k2h k2k k2l k2e" | ||
13 | |||
14 | BASEDIR = "${WORKDIR}/git" | ||
15 | S = "${BASEDIR}/ti/drv/cppi" | ||
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb new file mode 100755 index 00000000..bb2028b5 --- /dev/null +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "TI CPPI Module low level driver" | ||
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | |||
4 | DEPENDS = "common-csl-ip rm-lld qmss-lld" | ||
5 | |||
6 | include cppi-lld.inc | ||
7 | |||
8 | do_compile () { | ||
9 | # Now build the lld in the updated directory | ||
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
11 | for device in ${DEVICELIST} | ||
12 | do | ||
13 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" | ||
14 | done | ||
15 | } | ||
16 | |||
17 | do_install () { | ||
18 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
19 | } | ||