summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cppi-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-12-17 00:12:10 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-12-18 12:43:27 -0500
commit70664faa8da48c0c8cfed96c89c038017b8bfea1 (patch)
tree3a4a876e29d72ed17b58b7e9db6e5d8d300ddbc0 /recipes-bsp/cppi-lld
parent123dac8c82f03f117b3fdf361c9592304071983f (diff)
downloadmeta-ti-70664faa8da48c0c8cfed96c89c038017b8bfea1.tar.gz
cppi-lld: Add new recipe for CPPI Module low level driver
- Provides low level driver and test code for Communications port programming interface module - Supports k2h, k2k, k2l k2e devices Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rwxr-xr-xrecipes-bsp/cppi-lld/cppi-lld-test_git.bb26
-rw-r--r--recipes-bsp/cppi-lld/cppi-lld.inc15
-rwxr-xr-xrecipes-bsp/cppi-lld/cppi-lld_git.bb19
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb
new file mode 100755
index 00000000..871546e3
--- /dev/null
+++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "TI CPPI low level driver unit test and example binaries"
2COMPATIBLE_MACHINE = "keystone"
3DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld"
4
5include cppi-lld.inc
6
7CHOICELIST = "yes no"
8
9do_compile () {
10# Now build the lld in the updated directory
11 for device in ${DEVICELIST}
12 do
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S}
14 for choice in ${CHOICELIST}
15 do
16 make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
17 done
18 done
19}
20
21do_install () {
22 for device in ${DEVICELIST}
23do
24 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" CPPI_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
25 done
26}
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc
new file mode 100644
index 00000000..d26adc59
--- /dev/null
+++ b/recipes-bsp/cppi-lld/cppi-lld.inc
@@ -0,0 +1,15 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
3
4BRANCH = "master"
5SRC_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git;destsuffix=git/ti/drv/cppi;protocol=git;branch=${BRANCH}"
6
7# Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.06"
8SRCREV = "4c6c0a857786c49d8003453d3bc7c3c97ff4f5a4"
9PV = "02.01.00.06"
10PR = "r0"
11
12DEVICELIST = "k2h k2k k2l k2e"
13
14BASEDIR = "${WORKDIR}/git"
15S = "${BASEDIR}/ti/drv/cppi"
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb
new file mode 100755
index 00000000..bb2028b5
--- /dev/null
+++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "TI CPPI Module low level driver"
2COMPATIBLE_MACHINE = "keystone"
3
4DEPENDS = "common-csl-ip rm-lld qmss-lld"
5
6include cppi-lld.inc
7
8do_compile () {
9# Now build the lld in the updated directory
10 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR}
11 for device in ${DEVICELIST}
12 do
13 make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}"
14 done
15}
16
17do_install () {
18 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
19}