summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/cppi-lld
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2015-11-04 01:47:10 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-11-04 09:56:48 -0500
commitf9410c080415bce2d6b4ecd7e32655f18650f895 (patch)
treed8623377aca0370e914120175f3c3c20725b6617 /recipes-bsp/cppi-lld
parent2801ef9ce5fc3846e61c99e16b39f553e65c632d (diff)
downloadmeta-ti-f9410c080415bce2d6b4ecd7e32655f18650f895.tar.gz
cppi-lld: Only build binaries relevent to the machine
* Due to this change, the init script is no longer needed Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rw-r--r--recipes-bsp/cppi-lld/cppi-lld-test_git.bb1
-rw-r--r--recipes-bsp/cppi-lld/cppi-lld.inc9
-rw-r--r--recipes-bsp/cppi-lld/cppi-lld_git.bb22
-rwxr-xr-xrecipes-bsp/cppi-lld/files/init_cppi.sh47
4 files changed, 16 insertions, 63 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb
index 8f4856a8..b4f5c239 100644
--- a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb
+++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb
@@ -1,5 +1,4 @@
1DESCRIPTION = "TI CPPI low level driver unit test and example binaries" 1DESCRIPTION = "TI CPPI low level driver unit test and example binaries"
2COMPATIBLE_MACHINE = "keystone"
3DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" 2DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld"
4 3
5include cppi-lld.inc 4include cppi-lld.inc
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc
index ae81a3f0..cbcad346 100644
--- a/recipes-bsp/cppi-lld/cppi-lld.inc
+++ b/recipes-bsp/cppi-lld/cppi-lld.inc
@@ -1,6 +1,9 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" 2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d"
3 3
4COMPATIBLE_MACHINE = "keystone"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
4CPPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git" 7CPPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git"
5CPPI_LLD_GIT_PROTOCOL = "git" 8CPPI_LLD_GIT_PROTOCOL = "git"
6CPPI_LLD_GIT_BRANCH = "master" 9CPPI_LLD_GIT_BRANCH = "master"
@@ -14,8 +17,10 @@ SRC_URI = "${CPPI_LLD_GIT_URI};destsuffix=${CPPI_LLD_GIT_DESTSUFFIX};protocol=${
14 17
15SRCREV = "${CPPI_LLD_SRCREV}" 18SRCREV = "${CPPI_LLD_SRCREV}"
16PV = "02.01.00.10" 19PV = "02.01.00.10"
17INC_PR = "r1" 20INC_PR = "r2"
18 21
19DEVICELIST = "k2h k2k k2l k2e" 22DEVICELIST_k2hk-evm = "k2h k2k"
23DEVICELIST_k2l-evm = "k2l"
24DEVICELIST_k2e-evm = "k2e"
20 25
21S = "${WORKDIR}/${CPPI_LLD_GIT_DESTSUFFIX}" 26S = "${WORKDIR}/${CPPI_LLD_GIT_DESTSUFFIX}"
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb
index 169e0fcb..edbc35dd 100644
--- a/recipes-bsp/cppi-lld/cppi-lld_git.bb
+++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb
@@ -1,18 +1,10 @@
1DESCRIPTION = "TI CPPI Module low level driver" 1DESCRIPTION = "TI CPPI Module low level driver"
2COMPATIBLE_MACHINE = "keystone"
3 2
4DEPENDS = "common-csl-ip rm-lld qmss-lld" 3DEPENDS = "common-csl-ip rm-lld qmss-lld"
5 4
6include cppi-lld.inc 5include cppi-lld.inc
7 6
8PR = "${INC_PR}.0" 7PR = "${INC_PR}.1"
9
10SRC_URI += "file://init_cppi.sh"
11
12inherit update-rc.d
13
14INITSCRIPT_NAME = "init_cppi.sh"
15INITSCRIPT_PARAMS = "defaults 10"
16 8
17do_compile () { 9do_compile () {
18# Now build the lld in the updated directory 10# Now build the lld in the updated directory
@@ -25,11 +17,15 @@ do_compile () {
25 17
26do_install () { 18do_install () {
27 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} 19 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
20
28# Set the generic device library symbolic link to default k2h 21# Set the generic device library symbolic link to default k2h
29 cd ${D}${libdir} 22 cd ${D}${libdir}
30 ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 23
24 # Link only the first device in the list
25 for device in ${DEVICELIST}
26 do
27 ln -sf libcppi_${device}.so.1.0.0 libcppi_device.so.1
28 break
29 done
31 ln -sf libcppi_device.so.1 libcppi_device.so 30 ln -sf libcppi_device.so.1 libcppi_device.so
32# Copy init scripts
33 install -d ${D}${sysconfdir}/init.d/
34 install -c -m 755 ${WORKDIR}/init_cppi.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
35} 31}
diff --git a/recipes-bsp/cppi-lld/files/init_cppi.sh b/recipes-bsp/cppi-lld/files/init_cppi.sh
deleted file mode 100755
index 7a602dab..00000000
--- a/recipes-bsp/cppi-lld/files/init_cppi.sh
+++ /dev/null
@@ -1,47 +0,0 @@
1#*
2#* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/
3#*
4#*
5#* Redistribution and use in source and binary forms, with or without
6#* modification, are permitted provided that the following conditions
7#* are met:
8#*
9#* Redistributions of source code must retain the above copyright
10#* notice, this list of conditions and the following disclaimer.
11#*
12#* Redistributions in binary form must reproduce the above copyright
13#* notice, this list of conditions and the following disclaimer in the
14#* documentation and/or other materials provided with the
15#* distribution.
16#*
17#* Neither the name of Texas Instruments Incorporated nor the names of
18#* its contributors may be used to endorse or promote products derived
19#* from this software without specific prior written permission.
20#*
21
22#! /bin/sh
23compatible=$(cat /proc/device-tree/compatible)
24
25cd /usr/lib
26case "$compatible" in
27 *k2hk*)
28 device=k2hk
29 ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1
30 ;;
31 *k2l*)
32 device=k2l
33 ln -sf libcppi_k2l.so.1.0.0 libcppi_device.so.1
34 ;;
35 *k2e*)
36 device=k2e
37 ln -sf libcppi_k2e.so.1.0.0 libcppi_device.so.1
38 ;;
39 *)
40 device=unknown
41 ;;
42esac
43
44if [ $device != unknown ]; then
45 ln -sf libcppi_device.so.1 libcppi_device.so
46 echo cppi library link established for device : $device
47fi