diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:10 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 09:56:48 -0500 |
commit | f9410c080415bce2d6b4ecd7e32655f18650f895 (patch) | |
tree | d8623377aca0370e914120175f3c3c20725b6617 /recipes-bsp/cppi-lld | |
parent | 2801ef9ce5fc3846e61c99e16b39f553e65c632d (diff) | |
download | meta-ti-f9410c080415bce2d6b4ecd7e32655f18650f895.tar.gz |
cppi-lld: Only build binaries relevent to the machine
* Due to this change, the init script is no longer needed
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld-test_git.bb | 1 | ||||
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld.inc | 9 | ||||
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld_git.bb | 22 | ||||
-rwxr-xr-x | recipes-bsp/cppi-lld/files/init_cppi.sh | 47 |
4 files changed, 16 insertions, 63 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb index 8f4856a8..b4f5c239 100644 --- a/recipes-bsp/cppi-lld/cppi-lld-test_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld-test_git.bb | |||
@@ -1,5 +1,4 @@ | |||
1 | DESCRIPTION = "TI CPPI low level driver unit test and example binaries" | 1 | DESCRIPTION = "TI CPPI low level driver unit test and example binaries" |
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" | 2 | DEPENDS = "common-csl-ip rm-lld cppi-lld qmss-lld" |
4 | 3 | ||
5 | include cppi-lld.inc | 4 | include cppi-lld.inc |
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc index ae81a3f0..cbcad346 100644 --- a/recipes-bsp/cppi-lld/cppi-lld.inc +++ b/recipes-bsp/cppi-lld/cppi-lld.inc | |||
@@ -1,6 +1,9 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "keystone" | ||
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
6 | |||
4 | CPPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git" | 7 | CPPI_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git" |
5 | CPPI_LLD_GIT_PROTOCOL = "git" | 8 | CPPI_LLD_GIT_PROTOCOL = "git" |
6 | CPPI_LLD_GIT_BRANCH = "master" | 9 | CPPI_LLD_GIT_BRANCH = "master" |
@@ -14,8 +17,10 @@ SRC_URI = "${CPPI_LLD_GIT_URI};destsuffix=${CPPI_LLD_GIT_DESTSUFFIX};protocol=${ | |||
14 | 17 | ||
15 | SRCREV = "${CPPI_LLD_SRCREV}" | 18 | SRCREV = "${CPPI_LLD_SRCREV}" |
16 | PV = "02.01.00.10" | 19 | PV = "02.01.00.10" |
17 | INC_PR = "r1" | 20 | INC_PR = "r2" |
18 | 21 | ||
19 | DEVICELIST = "k2h k2k k2l k2e" | 22 | DEVICELIST_k2hk-evm = "k2h k2k" |
23 | DEVICELIST_k2l-evm = "k2l" | ||
24 | DEVICELIST_k2e-evm = "k2e" | ||
20 | 25 | ||
21 | S = "${WORKDIR}/${CPPI_LLD_GIT_DESTSUFFIX}" | 26 | S = "${WORKDIR}/${CPPI_LLD_GIT_DESTSUFFIX}" |
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb index 169e0fcb..edbc35dd 100644 --- a/recipes-bsp/cppi-lld/cppi-lld_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -1,18 +1,10 @@ | |||
1 | DESCRIPTION = "TI CPPI Module low level driver" | 1 | DESCRIPTION = "TI CPPI Module low level driver" |
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | 2 | ||
4 | DEPENDS = "common-csl-ip rm-lld qmss-lld" | 3 | DEPENDS = "common-csl-ip rm-lld qmss-lld" |
5 | 4 | ||
6 | include cppi-lld.inc | 5 | include cppi-lld.inc |
7 | 6 | ||
8 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.1" |
9 | |||
10 | SRC_URI += "file://init_cppi.sh" | ||
11 | |||
12 | inherit update-rc.d | ||
13 | |||
14 | INITSCRIPT_NAME = "init_cppi.sh" | ||
15 | INITSCRIPT_PARAMS = "defaults 10" | ||
16 | 8 | ||
17 | do_compile () { | 9 | do_compile () { |
18 | # Now build the lld in the updated directory | 10 | # Now build the lld in the updated directory |
@@ -25,11 +17,15 @@ do_compile () { | |||
25 | 17 | ||
26 | do_install () { | 18 | do_install () { |
27 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
20 | |||
28 | # Set the generic device library symbolic link to default k2h | 21 | # Set the generic device library symbolic link to default k2h |
29 | cd ${D}${libdir} | 22 | cd ${D}${libdir} |
30 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | 23 | |
24 | # Link only the first device in the list | ||
25 | for device in ${DEVICELIST} | ||
26 | do | ||
27 | ln -sf libcppi_${device}.so.1.0.0 libcppi_device.so.1 | ||
28 | break | ||
29 | done | ||
31 | ln -sf libcppi_device.so.1 libcppi_device.so | 30 | ln -sf libcppi_device.so.1 libcppi_device.so |
32 | # Copy init scripts | ||
33 | install -d ${D}${sysconfdir}/init.d/ | ||
34 | install -c -m 755 ${WORKDIR}/init_cppi.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
35 | } | 31 | } |
diff --git a/recipes-bsp/cppi-lld/files/init_cppi.sh b/recipes-bsp/cppi-lld/files/init_cppi.sh deleted file mode 100755 index 7a602dab..00000000 --- a/recipes-bsp/cppi-lld/files/init_cppi.sh +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | #* | ||
2 | #* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ | ||
3 | #* | ||
4 | #* | ||
5 | #* Redistribution and use in source and binary forms, with or without | ||
6 | #* modification, are permitted provided that the following conditions | ||
7 | #* are met: | ||
8 | #* | ||
9 | #* Redistributions of source code must retain the above copyright | ||
10 | #* notice, this list of conditions and the following disclaimer. | ||
11 | #* | ||
12 | #* Redistributions in binary form must reproduce the above copyright | ||
13 | #* notice, this list of conditions and the following disclaimer in the | ||
14 | #* documentation and/or other materials provided with the | ||
15 | #* distribution. | ||
16 | #* | ||
17 | #* Neither the name of Texas Instruments Incorporated nor the names of | ||
18 | #* its contributors may be used to endorse or promote products derived | ||
19 | #* from this software without specific prior written permission. | ||
20 | #* | ||
21 | |||
22 | #! /bin/sh | ||
23 | compatible=$(cat /proc/device-tree/compatible) | ||
24 | |||
25 | cd /usr/lib | ||
26 | case "$compatible" in | ||
27 | *k2hk*) | ||
28 | device=k2hk | ||
29 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | ||
30 | ;; | ||
31 | *k2l*) | ||
32 | device=k2l | ||
33 | ln -sf libcppi_k2l.so.1.0.0 libcppi_device.so.1 | ||
34 | ;; | ||
35 | *k2e*) | ||
36 | device=k2e | ||
37 | ln -sf libcppi_k2e.so.1.0.0 libcppi_device.so.1 | ||
38 | ;; | ||
39 | *) | ||
40 | device=unknown | ||
41 | ;; | ||
42 | esac | ||
43 | |||
44 | if [ $device != unknown ]; then | ||
45 | ln -sf libcppi_device.so.1 libcppi_device.so | ||
46 | echo cppi library link established for device : $device | ||
47 | fi | ||