diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-04-10 20:11:02 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-04-10 13:59:25 -0400 |
commit | 58d45b9abd67de8246822f8ac4e4f0363d7ef640 (patch) | |
tree | ccd708fc0021f030ee01b968935876f59372474c /recipes-bsp/cppi-lld | |
parent | bbe8b4f17d7c1adb140deea5ff35671e11e4f42b (diff) | |
download | meta-ti-58d45b9abd67de8246822f8ac4e4f0363d7ef640.tar.gz |
cppi-lld: Update to new version 2.1.0.8
- Add init script for creating symbolic link for generic device library boot time
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/cppi-lld')
-rw-r--r-- | recipes-bsp/cppi-lld/cppi-lld.inc | 8 | ||||
-rwxr-xr-x | recipes-bsp/cppi-lld/cppi-lld_git.bb | 16 | ||||
-rwxr-xr-x | recipes-bsp/cppi-lld/files/init_cppi.sh | 47 |
3 files changed, 66 insertions, 5 deletions
diff --git a/recipes-bsp/cppi-lld/cppi-lld.inc b/recipes-bsp/cppi-lld/cppi-lld.inc index d26adc59..0a8ee55f 100644 --- a/recipes-bsp/cppi-lld/cppi-lld.inc +++ b/recipes-bsp/cppi-lld/cppi-lld.inc | |||
@@ -4,10 +4,10 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/cppi/COPYING.txt;md5=e8f6789acd | |||
4 | BRANCH = "master" | 4 | BRANCH = "master" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git;destsuffix=git/ti/drv/cppi;protocol=git;branch=${BRANCH}" | 5 | SRC_URI = "git://git.ti.com/keystone-rtos/cppi-lld.git;destsuffix=git/ti/drv/cppi;protocol=git;branch=${BRANCH}" |
6 | 6 | ||
7 | # Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.06" | 7 | # Below Commit ID corresponds to "DEV.CPPI_LLD.02.01.00.08" |
8 | SRCREV = "4c6c0a857786c49d8003453d3bc7c3c97ff4f5a4" | 8 | SRCREV = "320af092dc382af52b9e68f14ca8acd5c1c467c1" |
9 | PV = "02.01.00.06" | 9 | PV = "02.01.00.09" |
10 | PR = "r0" | 10 | PR = "r1" |
11 | 11 | ||
12 | DEVICELIST = "k2h k2k k2l k2e" | 12 | DEVICELIST = "k2h k2k k2l k2e" |
13 | 13 | ||
diff --git a/recipes-bsp/cppi-lld/cppi-lld_git.bb b/recipes-bsp/cppi-lld/cppi-lld_git.bb index bb2028b5..cd419f6a 100755 --- a/recipes-bsp/cppi-lld/cppi-lld_git.bb +++ b/recipes-bsp/cppi-lld/cppi-lld_git.bb | |||
@@ -5,15 +5,29 @@ DEPENDS = "common-csl-ip rm-lld qmss-lld" | |||
5 | 5 | ||
6 | include cppi-lld.inc | 6 | include cppi-lld.inc |
7 | 7 | ||
8 | SRC_URI += "file://init_cppi.sh" | ||
9 | |||
10 | inherit update-rc.d | ||
11 | |||
12 | INITSCRIPT_NAME = "init_cppi.sh" | ||
13 | INITSCRIPT_PARAMS = "defaults 10" | ||
14 | |||
8 | do_compile () { | 15 | do_compile () { |
9 | # Now build the lld in the updated directory | 16 | # Now build the lld in the updated directory |
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | 17 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} |
11 | for device in ${DEVICELIST} | 18 | for device in ${DEVICELIST} |
12 | do | 19 | do |
13 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" | 20 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" |
14 | done | 21 | done |
15 | } | 22 | } |
16 | 23 | ||
17 | do_install () { | 24 | do_install () { |
18 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 25 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
26 | # Set the generic device library symbolic link to default k2h | ||
27 | cd ${D}${libdir} | ||
28 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | ||
29 | ln -sf libcppi_device.so.1 libcppi_device.so | ||
30 | # Copy init scripts | ||
31 | install -d ${D}${sysconfdir}/init.d/ | ||
32 | install -c -m 755 ${WORKDIR}/init_cppi.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
19 | } | 33 | } |
diff --git a/recipes-bsp/cppi-lld/files/init_cppi.sh b/recipes-bsp/cppi-lld/files/init_cppi.sh new file mode 100755 index 00000000..7a602dab --- /dev/null +++ b/recipes-bsp/cppi-lld/files/init_cppi.sh | |||
@@ -0,0 +1,47 @@ | |||
1 | #* | ||
2 | #* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ | ||
3 | #* | ||
4 | #* | ||
5 | #* Redistribution and use in source and binary forms, with or without | ||
6 | #* modification, are permitted provided that the following conditions | ||
7 | #* are met: | ||
8 | #* | ||
9 | #* Redistributions of source code must retain the above copyright | ||
10 | #* notice, this list of conditions and the following disclaimer. | ||
11 | #* | ||
12 | #* Redistributions in binary form must reproduce the above copyright | ||
13 | #* notice, this list of conditions and the following disclaimer in the | ||
14 | #* documentation and/or other materials provided with the | ||
15 | #* distribution. | ||
16 | #* | ||
17 | #* Neither the name of Texas Instruments Incorporated nor the names of | ||
18 | #* its contributors may be used to endorse or promote products derived | ||
19 | #* from this software without specific prior written permission. | ||
20 | #* | ||
21 | |||
22 | #! /bin/sh | ||
23 | compatible=$(cat /proc/device-tree/compatible) | ||
24 | |||
25 | cd /usr/lib | ||
26 | case "$compatible" in | ||
27 | *k2hk*) | ||
28 | device=k2hk | ||
29 | ln -sf libcppi_k2h.so.1.0.0 libcppi_device.so.1 | ||
30 | ;; | ||
31 | *k2l*) | ||
32 | device=k2l | ||
33 | ln -sf libcppi_k2l.so.1.0.0 libcppi_device.so.1 | ||
34 | ;; | ||
35 | *k2e*) | ||
36 | device=k2e | ||
37 | ln -sf libcppi_k2e.so.1.0.0 libcppi_device.so.1 | ||
38 | ;; | ||
39 | *) | ||
40 | device=unknown | ||
41 | ;; | ||
42 | esac | ||
43 | |||
44 | if [ $device != unknown ]; then | ||
45 | ln -sf libcppi_device.so.1 libcppi_device.so | ||
46 | echo cppi library link established for device : $device | ||
47 | fi | ||